WordPress.org

Support

Support » How-To and Troubleshooting » Facebook feed does not grab my post

Facebook feed does not grab my post

  • I’m working on getting a new template installed on my blog. Something about this theme is interfering with my Facebook posting. If I add the ling to a blog post (ex, http://www.fellowtravelerblog.com/2011/04/29/this-is-a-test/) to my feed, it only shows my header and favicon image and the blog title. No image from the post and no text either. FB does not see the post. I’ve done this lots with other WP sites, so I know it has to be a problem with this particular theme. Here is the header text in case anyone wants to take a look. I’m thinking this is probably where the problem is at:

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <title><?php if ( is_home() ) { ?><? bloginfo('name'); ?> - <?php bloginfo('description'); } else { wp_title(''); ?> - <? bloginfo('name'); } ?></title>
    <meta http-equiv="content-type" content="text/html; charset=iso-8859-1" />
    <link href="<?php bloginfo('stylesheet_url'); ?>" rel="stylesheet" type="text/css" />
    <link rel="stylesheet" href="<?php bloginfo('template_url'); ?>/styles/nav.css" type="text/css" media="screen" />
    <link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="<?php bloginfo('rss2_url'); ?>" />
    <link rel="alternate" type="text/xml" title="RSS .92" href="<?php bloginfo('rss_url'); ?>" />
    <script type="text/javascript" src="<?php echo bloginfo('template_url'); ?>/scripts/dropdowns.js"></script>
    <script type="text/javascript" src="<?php bloginfo('template_url'); ?>/scripts/tabs.js"> </script>
    <?php wp_head(); ?>
    </head>
    <body> 
    
    <div id="bg">
    
    <!-- Menu Start -->
    <div class="menu">
    
    <ul>
       <li<?php if ( is_front_page() ) echo ' class="current_page_item"'; ?>><a>/"><span>Home</span></a>
       <?php wp_list_pages('title_li=' ); ?>
    </ul>
    <p class="mobile"><a href="?mobile">View Mobile Version</a></p>
    </div>
    <!-- Menu End -->
    
    <!-- Con Start -->
    <div class="con"><div class="con-top"><div class="con-bot">
    
    <!--start side left-->
    <div class="SL">
    
    <!-- header START -->
    <div class="header">
    <div class="logo">
     <?php if ( get_option('ddthemes_header') == 'logo' )
     { include (TEMPLATEPATH . "/logo-img.php"); } else
     { include (TEMPLATEPATH . "/logo-txt.php"); } ?>
    <h2><?php echo get_bloginfo( 'description' ); ?></h2>
    </div>
    <div class="date">
    <img src="http://www.fellowtravelerblog.com/wp-content/themes/newstoday/images/moto.jpg" />
    </div>
    
    </div>
    <!-- Header End -->
  • The topic ‘Facebook feed does not grab my post’ is closed to new replies.