Support » Plugin: No JS Social Sharing » Facebook Featured Image and Posts Data

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author webheadcoder

    (@webheadllc)

    Hi,

    It looks like it’s something to do with Facebook. Possibly caching or something not totally refreshing.

    I took a look at the site you have in your screenshot and your current sharing solution is using the same method that this plugin uses. The link to the Facebook sharer is nearly identical. One has an additional /sharer/ in the url, but facebook redirects it to the same place.

    I also copied the url of the heavymetal page and inserted it into this plugin and the image shows up fine for me. Could you maybe clear your cache and try again to see if it resolves itself?

    Thread Starter shirtguy72

    (@shirtguy72)

    Not sure of the issue here, tried everything I know. Cleared all cache including Cloudflare and my Firefox browser, re-scraped FB Debugger also tried adding the following in .htaccess …. No luck. I’m Stumped!

    <IfModule mod_headers.c>
      <FilesMatch ".(js|css|xml|png|jpg|jpeg|html)$">
        Header set Cache-Control "private"
      </FilesMatch>
    </IfModule>
    Thread Starter shirtguy72

    (@shirtguy72)

    Can you please try installing Rank Math SEO to see if there is an incompatibility there?

    Plugin Author webheadcoder

    (@webheadllc)

    I tried Rank Math SEO and the links are unaltered. It still works the same with the basic settings of Rank math seo.

    I’m not sure what else to suggest. The links in this plugin just append the current url to the facebook sharer url. So it goes directly to facebook where they read your page and decide what image to show. Have you tried maybe logging out of FB and logging back in, tried other browsers, how are other pages? Your main homepage also works for me if i simply add your url to the “u” parameter in the facebook sharer url.

    Thread Starter shirtguy72

    (@shirtguy72)

    I have tried everything, Google Chrome, Firefox, Samsung Browser on my phone.
    Even tried adding to the head ….
    <meta property=”fb:app_id” content=”***********”>
    So that Facebook Share Debugger has zero warnings.

    Have not tried pages, they carry no featured images, have only displayed share buttons on posts in the past.

    Plugin Author webheadcoder

    (@webheadllc)

    I updated the facebook link to not include the shortlink. maybe that will clear things up. Please try version 1.2 when you have a chance.

    Thread Starter shirtguy72

    (@shirtguy72)

    That worked! Facebook, Twitter and Email working fine. Pinterest does not as expected, has to do with the way I am handling image delivery. Thanks for taking the time and glad we both stuck it out to resolve, I really wanted to use this plugin! [Marked as Resolved]

    Plugin Author webheadcoder

    (@webheadllc)

    Awesome! Thanks for all your feedback!

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.