Support » Plugin: Revive Old Posts - Auto Post to Social Media » Facebook error with version 8.0.0

  • Resolved tjalexander70

    (@tjalexander70)



    When I updated to version 8.0.0, only my Twitter account showed and I received a message that I was using 2 Twitter accounts. I was not. Originally I had 1 Facebook and 1 Twitter.

    I deleted the old and then re-linked my Twitter, which seems fine. But, when I tried to re-add Facebook, I received this message from Facebook:

    Can’t Load URL: The domain of this URL isn’t included in the app’s domains. To be able to load this URL, add all domains and subdomains of your app to the App Domains field in your app settings.

    When redirected back to my site, I get this message:

    Fatal error: Uncaught Error: Call to a member function getValue() on null in /…/wp-content/plugins/tweet-old-post/includes/admin/services/class-rop-facebook-service.php:114 Stack trace: #0 /…/wp-includes/rest-api/class-wp-rest-server.php(936): Rop_Facebook_Service->authorize(Object(WP_REST_Request)) #1 /…/wp-includes/rest-api/class-wp-rest-server.php(321): WP_REST_Server->dispatch(Object(WP_REST_Request)) #2 /…/wp-includes/rest-api.php(266): WP_REST_Server->serve_request(‘/tweet-old-post…’) #3 /…/wp-includes/class-wp-hook.php(286): rest_api_loaded(Object(WP)) #4 /…/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #5 /…/wp-includes/plugin.php(515): WP_Hook->do_action(Array) #6 /…/wp-includes/class-wp.php(373): do_action_ref_array(‘ in /…/wp-content/plugins/tweet-old-post/includes/admin/services/class-rop-facebook-service.php on line 114

    I have only one domain. I looked at the page https://docs.revive.social/article/349-how-to-create-a-facebook-application-for-revive-old-post. I have not a clue what the problem is.

    • This topic was modified 3 months, 3 weeks ago by  tjalexander70.
Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Contributor Uriahs Victor

    (@uriahs-victor)

    Hi there, did you follow the exact steps on that article? Including adding your Site Url to the Facebook login area?

    There’s a small change that you might have to make. Please follow the video on that article and the steps word for word and come back and tell us if the issue still occurs

    Looking forward to your reply

    me too, on upgrade i found only twitter and facebook disappear, but i can’t add, try to delete all accounts and re-add but doesn’t work, neither fb or twitter. Facebook same error othe user, twitter page fatal error on redirect after got token

    @uriahs-victor I have the same problem getting Facebook to work. I set up a new app, but I can’t manually change ‘Use Strict Mode for Redirect URIs’ from yes to no. Any ideas?

    Same here. I use the plugin on several websites and all are missing the Facebook account. Not impressed with this obviously untested update!

    Plugin Contributor Uriahs Victor

    (@uriahs-victor)

    @bobsled there seems to be an issue adding accounts where a *new* facebook app is created, I’ve added the issue on github for our developers to look into.

    Please try using your older Facebook app which you used for the previous version of the plugin. If you still have issues then please create a separate thread so we can help you there.

    @charbonnier please send us a ticket to friends[at]revive.social so we can have a closer look at this.

    @uriahs-victor I tried my old FB app but it failed also. I know you guys are busy working on a fix, so I won’t open a new thread. Happy to wait. Twitter is working fine, so that’ll do for the moment.

    I am using the existing Facebook app which was used for the previous version of the plugin… and the only difference with the instruction is “Use Strict Mode for Redirect URIs” which FaceBook is not letting me change.

    I reverted to the previous version of Revive Old Post and everything went back to working normally.

    i rollback too and seems to work (facebook don’t let me too change option)

    Plugin Author Codeinwp

    (@codeinwp)

    Hey guys,

    We’ve rolled a new version of v8.0.1 which should fix this issue.

    Let me know if you need any other assistance.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.