Support » Plugin: WordPress Social Login (Facebook, Google, Twitter) » Facebook Error during Test

  • Resolved naomibuch

    (@naomibuch)


    Hello…

    Thanks for this wonderful plugin, Google and Twitter logged in successful, but I got the following error when testing Facebook….

    And I replaced my old Valid OAuth Redirect URIs to your plugin’s Valid OAuth Redirect URIs which is….
    mywebsite/openidcallback/facebook ….I replaced my website name with mywebsite to protect my website being on google search….

    <div style=”color:#a94442;background-color:#f2dede;padding:15px;margin-bottom:20px;text-align:center;border:1px solid #E6B3B2;font-size:18pt;”>TEST FAILED</div><div style=”color:#a94442;font-size:14pt;margin-bottom:20px;”>WARNING: Client secret is incorrect for this app. Please check the client secret and try again.<br/>Array
    (
    [error] => Array
    (
    [message] => Can’t Load URL: The domain of this URL isn’t included in the app’s domains. To be able to load this URL, add all domains and subdomains of your app to the App Domains field in your app settings.
    [type] => OAuthException
    [code] => 191
    [fbtrace_id] => Acpq781QNyWtEG-d4sz6NZc
    )

    )</div><div style="display:block;text-align:center;margin-bottom:4%;"></div>

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hello….

    Now it’s logging in with the facebook icon, but it’s not capturing the users Facebook avatar and it’s generating User_1 and so on with the email address Unknown user_1@facebook.com

    All the Facebook settings are configured properly, also when I scraped my URL all information about my website is showing properly with no errors…

    When I tested it on Facebook Graph API Explorer as seen below….please note that i modified my website URL and name where my conversation don’t show up on Google search…

    {
    “url”: “https://mywebsite.com/&#8221;,
    “type”: “website”,
    “title”: “The Buzz Forum”,
    “locale”: {
    “locale”: “en_us”
    },
    “image”: [
    {
    “url”: “https://mywebsite.com/wp-content/uploads/2019/07/TB6_3-1-1024×332.jpg&#8221;
    },
    {
    “url”: “https://www.mywebsite.wp-content/uploads/2019/07/TB6_3-1.jpg&#8221;,
    “secure_url”: “https://mywebsite./wp-content/uploads/2019/07/TB6_3-1.jpg&#8221;
    }
    ],
    “description”: “The Buzz Discussion Board”,
    “site_name”: “The Buzz Forums”,
    “updated_time”: “2019-09-03T12:01:10+0000”,
    “id”: “1604982716205841”,
    “application”: {
    “id”: “2154923147969751”,
    “name”: “Buzz Discussion Board”,
    “url”: “https://www.mywebsite.com/&#8221;
    }
    }

    Any ideas?

    Hello again…Sorry about so many questions….

    I tested the access token and all came up with fine with no errors and my app has permission to the following scopes:

    email, manage_pages, pages_show_list, pages_messaging, pages_messaging_phone_number, pages_messaging_subscriptions, public_profile

    Access Token Info
    App ID XXXXXXXXXXXX : Buzz Discussion Board
    Type User
    App-Scoped User ID
    Learn More
    XXXXXXXXXXX : Nancy Buzz
    User last installed this app via API N/A
    Issued (about 2 weeks ago)
    Expires Never
    Data Access Expires (in about 3 months)
    Valid True
    Origin Desktop
    Scopes email, manage_pages, pages_show_list, pages_messaging, pages_messaging_phone_number, pages_messaging_subscriptions, public_profile
    Granular Scopes
    manage_pages
    Applies to all objects
    pages_show_list
    Applies to all objects
    pages_messaging
    Applies to all objects
    pages_messaging_phone_number
    Applies to all objects
    pages_messaging_subscriptions
    Applies to all objects
    LANG

    Hello again…this issue is making me pull my hair out….I have two Facebook login accounts. One personal and one business. When I run the test with your plugin, it pulls up my personal Facebook account even though I am using my Business App ID and Secret App ID in your plugin settings.

    And then it says your secret App ID is incorrect….and then throws this error :

    URL Blocked: This redirect failed because the redirect URI is not whitelisted in the app’s Client OAuth Settings. Make sure Client and Web OAuth Login are on and add all your app domains as Valid OAuth Redirect URIs.

    When I log into my website it goes through the motions and redirects and generates User_1 and so on with the email address Unknown user_1@facebook.com

    Any help in this weird matter would be helpful…

    Thanks,
    Naomi

    Plugin Author miniOrange

    (@cyberlord92)

    Hi,

    Thank you for reaching out to us.

    I have read all of your questions. Please make the following changes in the custom app configurations.

    1. You mentioned that you have created the application using business account and when you run the test with your plugin, it pulls up your personal Facebook account. This is happening because you might be logged in with your personal account on your browser. So please logout from your Facebook account from your browser and the run the test configuration.

    2. The URL Blocked issue raised because you have not properly entered the redirect URL or any other credentials like App ID and App Secret. So please follow the steps given in the video link to configure facebook custom app.

    If you still face the same issue, please send us the screenshot of the error message. Also, Please share page link where you have shown the social login options on your website.

    [ Signature deleted ]

    • This reply was modified 4 months, 3 weeks ago by Jan Dembowski.
Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.