Support » Plugin: Yoast SEO » Facebook dont recognize my images

  • Resolved penchy

    (@penchy)


    Hi guys please help. I recently change my wordpress theme do to some problems and after i installed new theme facebook totaly dont recognize my images when share links from my web site. In facebook debugger i get 200 response code and grey rectangular image which is blank and after i hit scrape again that image dissapear and there is nothing any more. Even old pictures i on posts i shared directly last year dont show images any more. Whan try to debbug image link i get 404 error. 🙁 Im using YOAST SEO plugin for meta data i everything looks ok but there is no images at all. Im trying to solve this lasst 10 days with no succes. Please, please help. My web site is https://receptizasve.com.

    The page I need help with: [log in to see the link]

Viewing 13 replies - 1 through 13 (of 13 total)
  • HELP, ANYONE ???

    Plugin Support Michael Tina

    (@mikes41720)

    Could you please provide us a sample URL where the preview for the title, image, and description isn’t working as expected when sharing on Facebook?

    You might want to refer to this article for more information — https://kb.yoast.com/kb/facebook-sharing-updated-details/

    Hi Michael, i tried everything from that link and many others, i just cant find solution. Im not to techy guy. Here is one of link from my site so u can test it you self https://receptizasve.com/2018/09/pileci-paprikas-sa-noklicama/
    Just to say none of my web site links works, even the old one i shared yers ago suddenly dont show images on facebook posts i directly shared. Its realy weird.

    So when i go to debugger there is no image just grey empty square, and when klick scrap that grey empty image dissapear and there is nothing, no image at all. This is what i get on debugger all info:
    Based on the raw tags, we constructed the following Open Graph properties

    og:url	https://receptizasve.com/2018/09/pileci-paprikas-sa-noklicama/
    og:type	article
    og:title	PILECI PAPRIKAS SA NOKLICAMA
    og:image	https://receptizasve.com/wp-content/uploads/PAPRIKAĆ -SA-NOKLICAMA-2.jpg
    og:description	PILECI PAPRIKAS SA NOKLICAMA: SASTOJCI: Povrce 1 crveni luk 1-2 mrkve 1/2 kom celerovog korjena(moze,a ne mora) 1 crvena paprika 4 krompira 1 kasika paradajz pire (iz tube ili staklenke) voda za podliti paprikas 2-3 lovorova lista Meso 4 kom batka sa zabatkom 1 kom bijelo meso po zelji
    og:site_name	RECEPTI ZA SVE
    og:updated_time	1537476784
    article:published_time	1537482896
    article:modified_time	1537482896
    article:publisher	964140716972222
    ia:markup_url	
    ia:markup_url_dev	
    ia:rules_url	
    ia:rules_url_dev	
    og:image:alt	
    <meta charset="UTF-8" />
    <meta name="msapplication-TileImage" content="https://receptizasve.com/wp-content/uploads/2018/07/slika-999059-59efbc474d712-default-300x300.jpg" />
    <meta name="viewport" content="width=device-width, initial-scale=1" />
    <meta name="apple-mobile-web-app-capable" content="yes" />
    <meta name="apple-mobile-web-app-status-bar-style" content="black" />
    <meta itemprop="name" content="RECEPTI ZA SVE" />
    <meta itemprop="url" content="https://receptizasve.com" />
    <meta property="og:type" content="article" />
    <meta property="og:title" content="PILECI PAPRIKAS SA NOKLICAMA" />
    <meta property="og:description" content="PILECI PAPRIKAS SA NOKLICAMA:  SASTOJCI:    Povrce    1 crveni luk    1-2 mrkve    1/2 kom celerovog korjena(moze,a ne mora)    1 crvena paprika    4 krompira    1 kasika paradajz pire (iz tube ili staklenke)    voda za podliti paprikas    2-3 lovorova lista    Meso    4 kom batka sa zabatkom    1 kom bijelo meso    po zelji" />
    <meta property="og:image" content="https://receptizasve.com/wp-content/uploads/PAPRIKAĆ -SA-NOKLICAMA-2.jpg" />
    <meta property="og:url" content="https://receptizasve.com/2018/09/pileci-paprikas-sa-noklicama/" />
    <meta property="og:site_name" content="RECEPTI ZA SVE" />
    <meta property="article:publisher" content="https://www.facebook.com/NajboljiReceptiZaSve/" />
    <meta property="article:published_time" content="2018-09-20T22:34:56+00:00" />
    <meta property="article:modified_time" content="2018-09-20T22:34:56+00:00" />
    <meta property="og:updated_time" content="2018-09-20T22:34:56+00:00" />
    <meta property="og:image:width" content="640" />
    <meta property="og:image:height" content="482" />
    <meta name="twitter:card" content="summary_large_image" />
    <meta name="twitter:title" content="PILECI PAPRIKAS SA NOKLICAMA" />
    <meta name="twitter:description" content="PILECI PAPRIKAS SA NOKLICAMA:  SASTOJCI:    Povrce    1 crveni luk    1-2 mrkve    1/2 kom celerovog korjena(moze,a ne mora)    1 crvena paprika    4 krompira    1 kasika paradajz pire (iz tube ili staklenke)    voda za podliti paprikas    2-3 lovorova lista    Meso    4 kom batka sa zabatkom    1 kom bijelo meso    po zelji" />
    <meta name="twitter:image" content="https://receptizasve.com/wp-content/uploads/PAPRIKAĆ -SA-NOKLICAMA-2.jpg" />
    <meta name="twitter:site" content="@RZasve" />
    <meta name="description" content="PILECI PAPRIKAS SA NOKLICAMA: Isjeckate na kockice luk i prodinstate ga kratko na malo ulja.Dodate ociscenu i na kolutove isjecenu mrkvu..." />
    <meta name="twitter:card" content="summary_large_image" />
    <meta name="twitter:description" content="PILECI PAPRIKAS SA NOKLICAMA: Isjeckate na kockice luk i prodinstate ga kratko na malo ulja.Dodate ociscenu i na kolutove isjecenu mrkvu..." />
    <meta name="twitter:title" content="PILECI PAPRIKAS SA NOKLICAMA - RECEPTI ZA SVE" />
    <meta name="twitter:site" content="@RZasve" />
    <meta name="twitter:image" content="https://receptizasve.com/wp-content/uploads/PAPRIKAĆ -SA-NOKLICAMA-2.jpg" />
    <meta name="twitter:creator" content="@RZasve" />
    <meta name="generator" content="WordPress 4.9.8" />
    <meta name="msapplication-TileImage" content="https://receptizasve.com/wp-content/uploads/2018/07/slika-999059-59efbc474d712-default
    Plugin Support jerparx

    (@jerparx)

    We’ve checked the URL and found out that the open graph data on your site is not generated by Yoast but by a different plugin called MashShare. (see screenshot here)

    If you want Yoast to generate the OpenGraph data for your site, make sure to disable OpenGraph functionalities from your theme and other plugins.

    Hi Jerparx, i switched to Yoast when you replied to this thred adn still no luick with images on facebook. Yoast is again active last 3 days and nothing. Please help because i desperate. More than 20 days i cant properly share posts from my web site 🙁
    Here is my page source with YOAST plugin

    `<link rel=”pingback” href=”https://receptizasve.com/xmlrpc.php&#8221; />
    <title>RECEPTI ZA SVE – Recepti, zanimljivosti, uradi sam, ljekovito bilje i joĆĄ mnogo toga!!!</title>
    <script type=”text/javascript”>document.documentElement.className = document.documentElement.className.replace( /\bno-js\b/,’js’ );</script>
    <!– This site is optimized with the Yoast SEO plugin v8.3 – https://yoast.com/wordpress/plugins/seo/ –>
    <meta name=”description” content=”Recepti, zanimljivosti, uradi sam, ljekovito bilje i joĆĄ mnogo toga!!!”/>
    <link rel=”canonical” href=”https://receptizasve.com/&#8221; />
    <link rel=”next” href=”https://receptizasve.com/page/2/&#8221; />
    <meta property=”og:locale” content=”bs_BA” />
    <meta property=”og:type” content=”website” />
    <meta property=”og:title” content=”Recepti za sve” />
    <meta property=”og:description” content=”Najbolji recepti na netu samo za vas” />
    <meta property=”og:url” content=”https://receptizasve.com/&#8221; />
    <meta property=”og:site_name” content=”RECEPTI ZA SVE” />
    <meta property=”fb:app_id” content=”1971511933130378″ />
    <meta property=”og:image” content=”https://receptizasve.com/wp-content/uploads/2018/07/slika-999059-59efbc474d712-default.jpg&#8221; />
    <meta property=”og:image:secure_url” content=”https://receptizasve.com/wp-content/uploads/2018/07/slika-999059-59efbc474d712-default.jpg&#8221; />
    <meta property=”og:image:width” content=”480″ />
    <meta property=”og:image:height” content=”480″ />
    <meta name=”twitter:card” content=”summary_large_image” />
    <meta name=”twitter:description” content=”Recepti, zanimljivosti, uradi sam, ljekovito bilje i joĆĄ mnogo toga!!!” />
    <meta name=”twitter:title” content=”RECEPTI ZA SVE – Recepti, zanimljivosti, uradi sam, ljekovito bilje i joĆĄ mnogo toga!!!” />
    <meta name=”twitter:site” content=”@RZasve” />
    <meta name=”twitter:image” content=”https://receptizasve.com/wp-content/uploads/2018/07/slika-999059-59efbc474d712-default.jpg&#8221; />
    <script type=’application/ld+json’>{“@context”:”https:\/\/schema.org”,”@type”:”WebSite”,”@id”:”#website”,”url”:”https:\/\/receptizasve.com\/”,”name”:”RECEPTI ZA SVE”,”potentialAction”:{“@type”:”SearchAction”,”target”:”https:\/\/receptizasve.com\/?s={search_term_string}”,”query-input”:”required name=search_term_string”}}</script>
    <!– / Yoast SEO plugin. –>

    • This reply was modified 1 year, 9 months ago by penchy.
    Plugin Support devnihil

    (@devnihil)

    @penchy We rechecked the page at https://receptizasve.com/2018/09/pileci-paprikas-sa-noklicama/ and confirmed that the Yoast SEO plugin was generating the correct metadata for the Open Graph image. However, in the debugger the following warning is being returned:

    Corrupted Image
    Provided og:image URL, https://receptizasve.com/wp-content/uploads/PAPRIKAĆ -SA-NOKLICAMA-2.jpg could not be processed as an image. It may be corrupted or may have an invalid format.

    Can you please try replacing the image with the one it is currently set to and rechecking in the debugger as to whether it will then load the correct image and resolve the warning?

    Hi Devnihil, i justn replaced this image with new one if that is what you sugessted and this is what i get on debugger.

    Provided og:image, https://receptizasve.com/wp-content/uploads/hqdefault-1.jpg could not be downloaded. This can happen due to several different reasons such as your server using unsupported content-encoding. The crawler accepts deflate and gzip content encodings.

    I did dotice this happpen in same time as i conected my site via Cloudflare. It worked few days and then just stopped. My first culprit was theme but when i restore to old theme i get same error again.
    Any ideas?

    • This reply was modified 1 year, 9 months ago by penchy.
    • This reply was modified 1 year, 9 months ago by penchy.
    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    This is to be expected to see the error in the Facebook debugger as the given image cannot be accessible and we’re also seeing the following error:

    Access to receptizasve.com was denied
    You don't have authorization to view this page.
    HTTP ERROR 403
    

    This issue isn’t something specific to Yoast SEO but specific to your setup. You must need to choose an image which needs to be accessible by others.

    Hi Md Mazedul Islam Khan, i dont know how you mean choose an image accessible by others. All my images upload normaly opn my wordpress site just like before. What happen that facebook canot acess it thats what im trying to figure. Any help is apriciated. Thanks

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    It’s not just Facebook, we’re also unable to see the image that you’ve shared and here it is https://receptizasve.com/wp-content/uploads/hqdefault-1.jpg. This image isn’t loading at all on our end.

    Last two days Twitter and Pineterest pick up images normaly, only facebook still not working, even old images i shared years ago on post are no longer aveilable 🙁 I have no idea what to do. And i also noticed that images are possible to open before i publish post on facebook, but after i try that post on debugger image becomes unavailable and gets 403 error. Weird no?

    Check this image, didnt share it yet on facebook and works fine. As son i share it on social media no more acess : https://receptizasve.com/wp-content/uploads/Izrezak.jpg

    Plugin Support devnihil

    (@devnihil)

    This may be due to the security settings on your server. Some servers use protection that causes images to not be loaded from other sources other than the website to prevent bandwidth leeching. We would recommend checking with your hosting provider to see if this or another security feature is enabled that would prevent the images from loading. A 403 error is caused when the requested action is not allowed on the server due to security or permission restrictions.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Facebook dont recognize my images’ is closed to new replies.