Support » Plugin: Yoast SEO » Facebook don’t read OpenGraph tags

Viewing 5 replies - 1 through 5 (of 5 total)
  • Tien Nguyen


    What is your site URL?

    Plugin Support MariusG


    In the Sharing Debugger, if you scroll all the way down, you can see exactly what Facebook sees when crawling your website (i.e. this image). You can use that link to determine if Facebook is properly crawling your pages.

    If there are any issues, it could either be something in your robots.txt file or a firewall/security plugin that you might be using that is blocking Facebook’s crawlers.

    ​Please let us know if you have any other questions or need any help.



    Plugin Support devnihil


    @michaelukr If you are seeing unexpected behavior or appearance for one of your site’s social previews when sharing it on social media, this can be caused by the social media site caching old metadata for that page. This is why you may not immediately see the new values you set up for the page reflected in the page’s preview when you share it (image, title, description, etc).

    To resolve this, we would first recommend to try checking your page’s link using Facebook’s Sharing Debugger tool located at Can you please try running the Facebook Sharing Debugger on the page you are experiencing the issue on, and under ‘When and how we last scraped the URL’ clicking the ‘Scrape Again’ option and letting us know whether this resolves the issue? The ‘Scrape Again’ option will force Facebook to update it’s cache for your page’s link.

    Please note that to successfully update the cache it may require re-scraping your page several times as whether the page’s data can be read may take several requests between Facebook and the server your website is hosted on. Also, this guide includes more information on this and explains in detail how to do this:

    Plugin Support Michael Tina


    No further response, setting to resolved.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Facebook don’t read OpenGraph tags’ is closed to new replies.