Support » Fixing WordPress » Facebook doesnt show thumbnail on share

  • Hello, I am trying to share a blog post on my facebook page, previously I have had no issues but currently the thumbnail image is not showing. I ran the page through facebook debugger and get the following error message:

    The following properties are specified on the webpage but NOT supported for the specified ‘og:type’: article:section, article:published_time, article:modified_time

    On occasion when I debug again I also get an error that the image itself cannot be processed because it is either corrupted or of the wrong format. I have tried changing the image format from .jpg to .png with no success.

    Also, this problem is occurring with some old images and posts I have previously shared with no issue. Comparing source codes with each other I don’t see anything abnormal.

    Lastly, today the sharing feature began working when sharing via phone, but not on any desktop platform.

    Any ideas anyone? Thanks !

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi,

    So know this is probably going to sound simple but clear your cache if and when you make updates otherwise Facebook won’t pick up changes immediately.

    Also ensure that the images being used for your feature image are in the dimensions supported by Facebook (or close to that at least) – too small and the images don’t get used.

    Also what sometimes helps is if you setup and make use of Yoast SEO plugin, setup the Social Media meta so that it ‘forces’ the use of your featured image when sharing and then defaults to a default site image if no featured image is picked up.

    Hope some of these suggestions help…

    Thread Starter aaronorbis

    (@aaronorbis)

    Hi Katanga,

    Thanks for your reply. I tried clearing my cache, resizing the image properly, and using the Yoast SEO plugin. Unfortunately though I’m having the same problem again but with a different page (the original page I posted started working by itself after my first post).

    This is the link I’m having trouble with:
    http://orbishealth.ca/vaping-healthier-smoking/

    Any help would be appreciated.

    Thread Starter aaronorbis

    (@aaronorbis)

    Update:

    I tried copying over all the content to a new post which is now sharing properly.

    But I’m still curious as to why the problem occurred in the first place so I don’t run into it in the future.

    Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Facebook doesnt show thumbnail on share’ is closed to new replies.