WordPress.org

Forums

Social Count Plus
[resolved] Facebook counter says "0" (22 posts)

  1. gcluley
    Member
    Posted 1 year ago #

    The last couple of weeks, the Facebook counter on my website (at grahamcluley [dot] com) has been saying "0". :(

    However, when I query Facebook to see what the plugin should be extracting for my Facebook count using http://graph.facebook.com/PAGE-ID it correctly reports over 5000+

    Am I doing something wrong? Note: It *was* working correctly, but recently stopped.

    Thanks

    http://wordpress.org/plugins/social-count-plus/

  2. Claudio Sanches
    Member
    Plugin Author

    Posted 1 year ago #

    What is the ID of your page?

  3. gcluley
    Member
    Posted 1 year ago #

    The ID is 'grahamcluleycom'

    Sometimes it shows the correct number on my website (check at http://grahamcluley.com). Other times (quite often :( ) it says zero.

    Thanks for looking into it.

  4. Claudio Sanches
    Member
    Plugin Author

    Posted 1 year ago #

    What is the ID?
    In number!
    I ask the same in the plugin settings!

  5. gcluley
    Member
    Posted 1 year ago #

    Apologies!

    140548966129675

  6. Claudio Sanches
    Member
    Plugin Author

    Posted 1 year ago #

    Using it in this plugin?

  7. gcluley
    Member
    Posted 1 year ago #

    yes, as you can see here

    https://files.app.net/tqk2X0Im.png

    Sometimes the plugin returns that my FB page has zero likes. Othertimes it reports the number (over 6000) correctly.

    Thanks

  8. Emilien Laborde
    Member
    Posted 1 year ago #

    Same problem for me, my FB page has zero likes. And my page id is correctly set.

  9. Doremdou
    Member
    Posted 1 year ago #

    Hello,
    I have the same problem, everything is working but not the facebook counter.
    Yesterday, it was working fine and it was displaying the correct amount of FB likes.
    And today it does not work anymore, and I didnt change anything. It is like this since I installed the plugin, some weeks ago.
    I suppose it will work again in a few hours, but I dont understand why it is working and then not working, working, not working... any explanation to this? How can we fix this problem?

    Thank you a lot for your plugin and answers
    keep up the good work,

    Dorem

    Sorry for my bad english

  10. Claudio Sanches
    Member
    Plugin Author

    Posted 1 year ago #

    this week I will update the form that takes the count of Facebook and let's see if it will help.

  11. Doremdou
    Member
    Posted 1 year ago #

    ok thank you :)

  12. Paul Thomson
    Member
    Posted 1 year ago #

    Hello Claudio,

    Firstly, congrats on the plugin, it really is excellent and thank you for continually providing support and development, you're a credit to the plugin community.

    I've been having similar issues with the facebook counter for months now.

    I've found that sometimes (maybe 30%) of the time, the facebook counter displays '0', also it doesn't seem to purge the cache on post 'updates' (does it also purge on Custom Post Type updates/publishes?)?

    An example page on my site: http://www.festivalarchive.com/event/iowa-city-jazz-festival-2014/

    I was wondering whether it might be possible to add a little check in the plugin to re-check a facebook page likes if == 0, perhaps loop this check 3 times as a failsafe? Then purge cache?

    Also maybe a manual purge button in the settings page might be good for testing?

    Note I'm using latest plugin version and latest WP version.

    Thanks,
    Paul

  13. Claudio Sanches
    Member
    Plugin Author

    Posted 1 year ago #

    It is clear only within 24 hours, but it is cleared when you save the settings of the plugin.

  14. Paul Thomson
    Member
    Posted 1 year ago #

    I was wondering whether it might be possible to add a little check in the plugin to re-check a facebook page likes if == 0, perhaps loop this check 3 times as a failsafe? Then purge cache?

  15. Claudio Sanches
    Member
    Plugin Author

    Posted 1 year ago #

    @Paul Thomson: feel free to send me a pull request https://github.com/claudiosmweb/social-count-plus

  16. rebelguru
    Member
    Posted 1 year ago #

    Hey Claudio, I have the same issue on both my sites as well:

    geekpr0n.com
    myfreakinears.com

    Sometimes it works, most of the time it shows 0. Let me know if there's anything I can do to fix that.

  17. koke1989
    Member
    Posted 1 year ago #

    Hey Claudio, I have the same problem: FB always shows 0

    http://www.javer-keleb.besaba.com/

    The ID is 1468571540026410

    Can I do to fix that?

    Thanks

  18. Claudio Sanches
    Member
    Plugin Author

    Posted 1 year ago #

    Fixed in 2.8.2.

  19. koke1989
    Member
    Posted 1 year ago #

    Hi Claudio, the plugin works perfectly with the last update but I have still the same problem with Facebook.

    Always shows "0". I don't know how to fix the problema.

    Can you help me find the error?, thank's

  20. Claudio Sanches
    Member
    Plugin Author

    Posted 1 year ago #

    Works fine: http://graph.facebook.com/1468571540026410
    Put Facebook icon in the widget and try clicking to save the plugin options twice...

    ...And then learn how to use the WordPress forum and not steal other topics:
    http://codex.wordpress.org/Forum_Welcome#Where_To_Post

  21. cytralskunk
    Member
    Posted 7 months ago #

    I had the same problem, but just disabled Quick Cache plugin on my site and the number is back.

  22. mariamrodrigo
    Member
    Posted 6 months ago #

    Hi Claudio, as i've already said, great work!!!

    I have a problem, my facebook counter says 0

    I got a system report and it says:

    ### FACEBOOK ###
    Array
    (
    [headers] => Array
    (
    [www-authenticate] => OAuth "Facebook Platform" "invalid_request" "(#4) Application request limit reached"
    [facebook-api-version] => v1.0
    [content-type] => application/json; charset=UTF-8
    [pragma] => no-cache
    [access-control-allow-origin] => *
    [x-fb-rev] => 1496061
    [cache-control] => no-store
    [expires] => Sat, 01 Jan 2000 00:00:00 GMT
    [x-fb-debug] => EHoFH8AThQYif3uW6hYJjnf2g9hxYCLA8aFW8GWnERm5FW4xQGEMx/O8f/9e+XJCBYjyeTt7rfhYVPNz+D3sPg==
    [date] => Sun, 16 Nov 2014 16:34:23 GMT
    [connection] => close
    [content-length] => 95
    )

    [body] => {"error":{"message":"(#4) Application request limit reached","type":"OAuthException","code":4}}
    [response] => Array
    (
    [code] => 403
    [message] => Forbidden
    )

    [cookies] => Array
    (
    )

    [filename] =>
    )

    I don't know where the problem is... could you help me, please?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Social Count Plus
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.