WordPress.org

Forums

WP-FB-AutoConnect
[resolved] Facebook could not validate your session key and secret (15 posts)

  1. RiseCakoPlusplus
    Member
    Posted 2 years ago #

    I have google and try to solve this by my own for more than 10 times. However it still showing:

    ERROR: Facebook could not validate your session key and secret! Are you sure you've entered them correctly?

    Yes, I have follow all the 7 steps. I even try to reinstall wordpress with just this plugin enabled but still now luck with same error. Hope anybody can help me.

    http://wordpress.org/extend/plugins/wp-fb-autoconnect/

  2. justin_k
    Member
    Plugin Author

    Posted 2 years ago #

    What 7 steps? The plugin support page is here: http://www.justin-klein.com/projects/wp-fb-autoconnect. You seem to have ignored the bold red note immediately above the support form.

  3. RiseCakoPlusplus
    Member
    Posted 2 years ago #

    This steps

    Setup Instructions
    To allow your users to login with their Facebook accounts, you must first setup a Facebook Application for your website:

    Visit developers.facebook.com/apps and click the "Create New App" button.
    Type in a name (i.e. the name of your website) and click "Continue." This is the name your users will see on the Facebook login popup.
    Facebook may now require you to verify your account before continuing (see here for more information).
    Once your app has been created, scroll down and fill in your "Site URL" under "Select how your app integrates with Facebook ->"Website." Note: http://example.com/ and http://www.example.com/ are not the same.
    Click "Save Changes."
    Copy the App ID and App Secret to the boxes below.
    Click "Save" below.

    Both of the link you just gave similar to that steps from login setting activation guides. Followed both still the same error.

  4. justin_k
    Member
    Plugin Author

    Posted 2 years ago #

    You've still ignored the bold red note. If you want help, you need to include the clearly-requested information.

  5. RiseCakoPlusplus
    Member
    Posted 2 years ago #

    Have you tried disabling all your other plugins and using the default theme (FAQ100)?
    Yes. I even install fresh WordPress.

    Have you tried recreating your Facebook app and reconnecting it to the plugin (FAQ100)?
    Yes. I reset secret key same result. So I create new app and same result. I done this more than 3 times.

    Have you tried it in another browser (FAQ35)?
    Currently using Firefox. Failed and I try to use Chrome. And worst case I try to use IE. No luck.

    Provide a link to the site that isn't working.
    http://www.cakobox.com/

    Provide the information from the "Support Info" tab of the plugin's admin panel.
    Firefox:
    WordPress Version: 3.4.2
    BuddyPress Version: Not Detected
    MultiSite Status: Not Allowed / Disabled
    Browser Version: Firefox 16.0 for Windows
    Plugin Version: 2.3.10
    Addon Version: Not Detected
    Facebook API: Already present!
    Theme: Vantage
    Server: Apache/2.2.22 (CentOS)
    cURL: Curl is available but cannot access Facebook! (0 - )
    Active Plugins: 17 (CloudFlare 1.3.7; Jetpack by WordPress.com 2.0; Mingle Forum 1.0.33.2; Mingle Image Gallery 1.0.00; Mingle 0.1.0; iCom Mingle Ninja ; qTranslate 2.5.32; Quick Browscap 1.03; Quick Chat 4.10; Quick Count 2.02; ShareThis 5.4; Shortcode Exec PHP 1.44; Wiki 1.2.2.6; WordPress SEO 1.2.8.7; WordPress Social Stream Downloaded From http://www.wpdb.org 1.4.1; WP-FB-AutoConnect 2.3.10; WP-Mail-SMTP 0.9.1; )

    Chrome:
    Wordpress Version: 3.4.2
    BuddyPress Version: Not Detected
    MultiSite Status: Not Allowed / Disabled
    Browser Version: Chrome 23.0.1271.64 for Windows
    Plugin Version: 2.3.10
    Addon Version: Not Detected
    Facebook API: Already present!
    Theme: Vantage
    Server: Apache/2.2.22 (CentOS)
    cURL: Curl is available but cannot access Facebook! (0 - )
    Active Plugins: 17 (CloudFlare 1.3.7; Jetpack by WordPress.com 2.0; Mingle Forum 1.0.33.2; Mingle Image Gallery 1.0.00; Mingle 0.1.0; iCom Mingle Ninja ; qTranslate 2.5.32; Quick Browscap 1.03; Quick Chat 4.10; Quick Count 2.02; ShareThis 5.4; Shortcode Exec PHP 1.44; Wiki 1.2.2.6; WordPress SEO 1.2.8.7; WordPress Social Stream Downloaded From http://www.wpdb.org 1.4.1; WP-FB-AutoConnect 2.3.10; WP-Mail-SMTP 0.9.1; )

    IE:
    Wordpress Version: 3.4.2
    BuddyPress Version: Not Detected
    MultiSite Status: Not Allowed / Disabled
    Browser Version: MSIE 9.0 for Windows
    Plugin Version: 2.3.10
    Addon Version: Not Detected
    Facebook API: OK
    Theme: Vantage
    Server: Apache/2.2.22 (CentOS)
    cURL: Curl is available but cannot access Facebook! (0 - )
    Active Plugins: 17 (CloudFlare 1.3.7; Jetpack by WordPress.com 2.0; Mingle Forum 1.0.33.2; Mingle Image Gallery 1.0.00; Mingle 0.1.0; iCom Mingle Ninja ; qTranslate 2.5.32; Quick Browscap 1.03; Quick Chat 4.10; Quick Count 2.02; ShareThis 5.4; Shortcode Exec PHP 1.44; Wiki 1.2.2.6; WordPress SEO 1.2.8.7; WordPress Social Stream Downloaded From http://www.wpdb.org 1.4.1; WP-FB-AutoConnect 2.3.10; WP-Mail-SMTP 0.9.1; )

  6. justin_k
    Member
    Plugin Author

    Posted 2 years ago #

    Finally.

    The debug information shows that cURL can't access Facebook, so something is clearly wrong with your server config; you'll almost certainly need to talk to your webhost about this. I just tried it on 2 different servers I administer and it's working as it always had.

    Just as an added test, you can try replacing AdminPage.php line 370 (the line above "curl_close") with the following, and again check the support info:

    else echo "<b>Curl is available but cannot access Facebook!</b> <small>(Errno: " . curl_errno($ch) ."; Error: ". curl_error($ch) ."; Reply: " . print_r($x,true)."</small>";
  7. justin_k
    Member
    Plugin Author

    Posted 2 years ago #

    In addition, you currently have a bunch of other plugins active. Turn them off when testing.

  8. RiseCakoPlusplus
    Member
    Posted 2 years ago #

    Replaced

    else echo "<b>Curl is available but cannot access Facebook!</b> (" . curl_errno($ch) ." - ". curl_error($ch) .")
    ";

    with

    else echo "<b>Curl is available but cannot access Facebook!</b> <small>(Errno: " . curl_errno($ch) ."; Error: ". curl_error($ch) ."; Reply: " . print_r($x,true)."</small>";

    And here the result:
    Wordpress Version: 3.4.2
    BuddyPress Version: Not Detected
    MultiSite Status: Not Allowed / Disabled
    Browser Version: Firefox 16.0 for Windows
    Plugin Version: 2.3.10
    Addon Version: Not Detected
    Facebook API: Already present!
    Theme: Vantage
    Server: Apache/2.2.22 (CentOS)
    cURL: Curl is available but cannot access Facebook! (Errno: 0; Error: ; Reply: Active Plugins: 1 (WP-FB-AutoConnect 2.3.10; )

    p/s: I am using (Centos 5)VPS with Kloxo as CP.

  9. justin_k
    Member
    Plugin Author

    Posted 2 years ago #

    It says that the Facebook API is already present. Please return to the default theme too. Do you not see a warning at the top of your WP-FB-AutoConnect admin panel?

  10. RiseCakoPlusplus
    Member
    Posted 2 years ago #

    Tried both
    Wordpress Version: 3.4.2
    BuddyPress Version: Not Detected
    MultiSite Status: Not Allowed / Disabled
    Browser Version: Firefox 16.0 for Windows
    Plugin Version: 2.3.10
    Addon Version: Not Detected
    Facebook API: Already present!
    Theme: Twenty Eleven
    Server: Apache/2.2.22 (CentOS)
    cURL: Curl is available but cannot access Facebook! (Errno: 0; Error: ; Reply: Active Plugins: 1 (WP-FB-AutoConnect 2.3.10; )

    WordPress Version: 3.4.2
    BuddyPress Version: Not Detected
    MultiSite Status: Not Allowed / Disabled
    Browser Version: Firefox 16.0 for Windows
    Plugin Version: 2.3.10
    Addon Version: Not Detected
    Facebook API: Already present!
    Theme: Twenty Ten
    Server: Apache/2.2.22 (CentOS)
    cURL: Curl is available but cannot access Facebook! (Errno: 0; Error: ; Reply: Active Plugins: 1 (WP-FB-AutoConnect 2.3.10; )

    Still see this same at top of my WP-FB-AutoConnect admin panel:

    ERROR: Facebook could not validate your session key and secret! Are you sure you've entered them correctly?

  11. justin_k
    Member
    Plugin Author

    Posted 2 years ago #

    I can't imagine how it could be detecting that the Facebook API is already present - that would literally be the first time that's ever been reported after more than 175,000 downloads. You can have a look in AdminPage.php, line 351: there's a class called 'facebook' somewhere in your code, though a truly default WordPress install absolutely does not have a facebook class. *Something* in your setup is not standard, whether it's a modification you made but aren't aware of or something weird on your webserver. You might want to do a global code search for 'facebook.'

    The only other thing I can recommend is to give it a try on another server to determine for certain whether or not it's a server issue. That line of code is pretty cut-and-dried: you have Facebook code somewhere else on your site, and it's conflicting with this plugin.

  12. RiseCakoPlusplus
    Member
    Posted 2 years ago #

    Ya. This problem bugging me for long times. Im not sure if my Cloudflare (DNS) does affect this.

    Btw, Thanks a lot for your times and sincerely Sorry because at first I did not understand the red bold things.

    For now, I am gonna try to use other DNS than Cloudflare, let it propagate and if any news I will update and let you know soon. :)

  13. justin_k
    Member
    Plugin Author

    Posted 2 years ago #

    Cloudflare is not a DNS, it's a CDN - yes, that's absolutely what's breaking it. As is mentioned in many of the FAQs, CDNs are likely to break this (and many other) plugins.

  14. RiseCakoPlusplus
    Member
    Posted 2 years ago #

    Haha. Ya forgot about the CDN that Cloudflare provide. Wish me luck. :D

  15. justin_k
    Member
    Plugin Author

    Posted 2 years ago #

    I guess this is resolved.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP-FB-AutoConnect
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic