Support » Plugin: LiteSpeed Cache » Facebook Conversion API Cache Problem on WordPress

  • Resolved pairfumlondon

    (@pairfumlondon)


    Dear Support,

    We have a caching issue with the Litespeed cache plugin and the FB Conversion API (i.e. server side events).

    We have implemented the FB pixel via the WP-plugin PixelYourSite, both as a browser pixel and as a server side event (conversion API).

    The issue we experience is described in this video:
    https://www.youtube.com/watch?reload=9&v=YH6ve7qj1hw

    You can easily replicate the issue by loading our website per the instructions in the video above:
    https://www.pairfum.com

    How do suggest that we solve this problem where it is specifically related to the Litespeed cache plugin and de-duplicating FB events?

    I look forward to your help with this issue.

    Pairfum London

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Support qtwrk

    (@qtwrk)

    Hi,

    Could you please provide the report number ?

    You can get it in toolbox -> report -> click “send to LiteSpeed”

    Best regards,

    Dear @qtwrk

    Many thanks for your reply and instructions. They were very easy to follow.

    Here is the report number:
    LiteSpeed Report
    Report number: ZTSMUIQC
    Report date: 09/30/2020 09:08:32

    I look forward to hearing back from you.

    Kind regards,

    Pairfum London

    Hi! I also need solution for this, please update this topic if You figure it out 👀 🙂

    Best!

    Dear @serwer20

    Many thanks for lending your support to this issue.

    We suspect most e-commerce website that use Litespeed and FB tracking (pixel & API) will experience this issue.

    Kind regards,

    Pairfum London

    Dear @qtwrk

    Would you have an update for us?

    Or, … even better, do you already have a solution?

    With kind regards,

    Pairfum London

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    Apologize for late response.

    could you please try disable JS push and JS defer, purge all ?

    Best regards,

    Dear @qtwrk

    Many thanks for the suggestion.

    We have tried it but sadly it did not make any difference, the event ID stays the same.

    As per your instructions:
    – we disabled JS push & defer via Litspeed Cache > Page Optimisation > JS HTTP/2 Push off & Load JS Deferred off
    – we then cleared the cache via Litespeed Cache > Toolbox > Empty Entire Cache
    – we also cleared the entire Cloudflare Cache,
    – last we ensured that the browser cache was clear and checked with the FB Pixel Helper in three different browsers: Chrome, Opera, New Edge (Chromium)

    We found that the event ID was the same in all three browsers.

    Would you like me to send you a new report number so you can investigate further?

    Many thanks for your help with this problem.

    Kind regards,

    Pairfum London

    Dear @qtwrk

    Another quick update:

    We switched-off the Litespeed Cache plugin and the problem was solved.

    We then tried the WP-Rocket Caching plugin and with this caching plugin we did not experience the issue.

    Hence, the issue is quite clearly associated with the Litespeed Cache plugin.

    Kind regards,

    Pairfum London

    Dear @qtwrk

    I was wondering whether excluding Facebook tracking from being cached might be a solution.

    This is what we have in mind:
    https://i.imgur.com/cbFFgrx.png

    These are the mentions of Facebook that we find on the ‘waterfall’ when we run our site through speed testing tools, e.g. Pingdome, WebPageTest.org.

    Could this work?

    Kind regards,

    Pairfum London

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    No , that is for your page’s URL

    could you please try reset to default setting and see if it works ?

    Best regards,

    Dear @qtwrk

    The author of the plugin PixelYourSite found a way to solve this issue for caching plugins like Litespeed by using Ajax.

    We found that this solution works for our website.

    Here is a screenshot to show this setting:
    https://i.imgur.com/ebNOwDP.png

    Many thanks for your help on this.

    With kind regards,

    Pairfum London

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.