Support » Plugins and Hacks » [Facebook Comments Plugin] Asks me for App ID although provided

  • do77

    (@do77)


    Hi,

    I am having trouble with the Facebook Comments Plugin. I installed the plugin and at first it worked well. But after deactivating it and reactivating the plugin it now keeps saying

    The comments plugin requires an application id to properly namespace the provided xid.

    I did properly enter the App ID so I am not quite sure why it does that. Any ideas?

    Thanks,
    do77

    P.S. I included Javascript SDK Open graph protocol myself and unchecked the boxes within the plugin administration.

Viewing 12 replies - 1 through 12 (of 12 total)
  • 007me

    (@007me)

    Hi

    having the very same problem and t started today.
    Does the plugin compatible with WordPress 3.0.5?

    thanks,

    me.

    do77

    (@do77)

    Ok, here comes the weird part:

    Even if I deactivate the plugin and manually add the code provided by Facebook I get the same message. Again: I did put in the app id!

    Any ideas? Could it be possible that there are some information stored in my database (from activating the plugin or so) that cause this behaviour?

    Many thanks!

    007me

    (@007me)

    Another weird part is that on some pages on WordPress it works and on others it doesn’t.

    do77

    (@do77)

    Hey 007me,

    so I think I figured out what causes the weird behavior. In addition to the comments I also added a like button on my page. While I already called the script

    <script src="http://connect.facebook.net/en_US/all.js#xfbml=1"></script>

    when loading the Javascript asynchronously I then again called the script with the like button

    <script src="http://connect.facebook.net/en_US/all.js#xfbml=1"></script><fb:like show_faces="true" width="450"></fb:like>

    After I removed the second call everything worked well and the comments where shown as supposed

    <fb:like show_faces="true" width="450"></fb:like>

    I am not sure if its the same in your case but at least for me it did it!

    007me

    (@007me)

    so you mean that my FB like has conflict with the FB comments?
    didn’t understand how to solve it.
    Will appreciate your help.

    do77

    (@do77)

    Yes, at least like button and comments were in conflict on my page. If you added your like button with XFBML it should look like this:

    <script src="http://connect.facebook.net/en_US/all.js#xfbml=1"></script><fb:like show_faces="true" width="450"></fb:like>

    Simply get rid off the script call and it should look like this:

    <fb:like show_faces="true" width="450"></fb:like>

    Then it should work!

    007me

    (@007me)

    Thanks, I will try that.

    007me

    (@007me)

    Well, I have the FB like plugin installed and not just the script.
    any solution for that?
    Also, just saw that there was an update to the FB comments plugin.
    I’ll try it as well.

    007me

    (@007me)

    I also disabled the FB like plugin and I’m still getting the “The comments plugin requires an application id to properly namespace the provided xid.” error.

    do77

    (@do77)

    Sorry, I don’t have a solution for that. Maybe you should just work without the like plugin put the actual code into your theme.

    thank you do77! that was my problem as well in the past couple days, thanks a bunch

    Try my new Facebook Comments plugin. This works with the new commenting system and is 5% of the size of the popular Comments plugin.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Facebook Comments Plugin] Asks me for App ID although provided’ is closed to new replies.