Support » Plugin: NextScripts: Social Networks Auto-Poster » Facebook autopost not displaying featured image

  • Hi there,
    I recently used this plugin to auto post on facebook. But the facebook posts are not displaying the featured image.
    It’s displaying the default featured image set with Default Featured Image plugin though . When I view page source of the particular post I can see the correct image on og:image .
    I have used WP User Frontend Pro plugin for the posts, Default Featured Image plugin for the default featured image if none provided.
    I have Selected Facebook as What should fill attachment info.

    Website URL: http://londonlostpets.ca/

    Please help me here.
    Thanks,
    Tushar

Viewing 15 replies - 1 through 15 (of 23 total)
  • Plugin Author NextScripts

    (@nextscripts)

    Hi, I checked the link you provided.
    This is the correct setting, isn’t it?
    SNAP settings : http://imgur.com/CGAUxyy

    This is the setting from the plugin Facebook Open Graph, Google+ and Twitter Card Tags:
    Facebook Open Graph, Google+ and Twitter Card Tags: http://imgur.com/SJvZKpC

    When I manually share the link, the featured image is showing but not when the post is automatically shared using Nextscripts plugin.

    i have the same issue.

    @tushar – did you find any solution?

    @pawciak Not yet 🙁 .

    Plugin Author NextScripts

    (@nextscripts)

    Please update plugin to the latest version 3.8.6. We made all necessary changes to accommodate new Facebook reality and improved our OG tags generation.

    If it doesn’t help, please download and configure any major SEO or OpenGraph plugin.

    Personally we usually use Yoast SEO. In hard cases when we need extremely fine tuned opengraph tags we use WPSSO

    @nextscripts Thanks for suggesting WPSSO. If you ever feel like suggesting a change to better integrate NextScripts with WPSSO, please let me know. 😉

    js.

    The reply to the original question is not satisfactory. I have also experienced the same issue. Autposting to Twitter works perfectly all the time but Facebook is becoming a problem. As of about a few days ago, the featured image is not picked. Instead the avatar of the author is shown. Sometimes it picks another image altogether. The “og:” tags are all set up correctly. Under the Facebook “post type” settings, it is correctly set to “Text Post with ‘attached’ link”. I have even put “Add Open Graph Tags” under Open Graph Tag settings but to no avail. I have the latest version of WordPress and the plugin. Please sort this problem out asap.

    I have the same issue.
    Newest version (3.8.6) with a working OG tags.
    IMPORTANT: When I edit the post and then click the “Post to Facebook” button from the NextScripts tab – if works perfectly. But the first (auto-posted) post – does not.

    • This reply was modified 9 months, 3 weeks ago by  omriamos.
    Plugin Author NextScripts

    (@nextscripts)

    When I edit the post and then click the “Post to Facebook” button from the NextScripts tab – if works perfectly. But the first (auto-posted) post – does not.

    This means your OG tags are not there yet at the time of autoposting. They are being added later.

    All my OG tags are managed by this plugin: https://wordpress.org/plugins/wonderm00ns-simple-facebook-open-graph-tags/

    I don’t know what do you mean by “later”, they exist on the post the second it is published.
    Anyway, how can that be fixed?

    Plugin Author NextScripts

    (@nextscripts)

    It can be fixed by setting OG tags correctly.

    As it stated above, Facebook recently took off the ability to change anything in the shared link details from our plugin.

    As of now, all our plugin is doing – it gives the Facebook the URL of your new post. The rest is between your site and Facebook itself.

    My OG tags ARE set correctly.

    Plugin Author NextScripts

    (@nextscripts)

    ok. Let me explain again.

    How SNAP worked before the July 18, 2017.

    1. You hit “Publish” button.
    2. WordPress changes the status of the post to “published” and calls the special hook from SNAP attached to that event.
    2. SNAP collects the post info, then calls Facebook and says “Hi Facebook. Here the URL of the link I want to publish on my Facebook page, this is the title for that link, this is the description, this is the image”.
    3. Facebook publishes the link with provided title, description and image

    How SNAP works after the July 18, 2017.

    1. You hit “Publish” button.
    2. WordPress changes the status of the post to “published” and calls the special hook from SNAP attached to that event.
    2. SNAP calls Facebook and says “Hi Facebook. Here the URL of the link I want to publish on my Facebook page.
    3. Facebook visits the provided URL, collects title, description and image from OG metatags and than publishes the link with collected from OG tags title, description and image.

    So please tell me what exactly we can do in this new reality where SNAP no longer can control what image, title and description will be published on Facebook?

    If you dont want to fix your OG tags, the only thins I can suggest is to set a delay before autoposting – https://www.nextscripts.com/snap-features/scheduled-and-delayed-posting/

    You’re missing a very simple and important fact.
    When I edit the post and then click the “Post to Facebook” button from the NextScripts tab – if works perfectly.
    But on the auto-published post, it took some random image from a different post.

    I don’t know what’s wrong, this might be caused by something else and not your plugin. But these are the facts (at least in my case).

    Plugin Author NextScripts

    (@nextscripts)

    As I already said, the only explanation for that is that at the time of the auto-publishing your OG tags are not there or incorrect.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘Facebook autopost not displaying featured image’ is closed to new replies.