Support » Plugin: Social Media Auto Publish » Facebook Authorization issues

  • Resolved Shameer

    (@shameeryou)


    Not able to authorize facebook developer app to auto publish.

    May have some changes from facebook side.. please look at it.

    When I tried to authorize
    Application needs authorisation
    im getting this error

    • This topic was modified 2 years, 9 months ago by Shameer.
Viewing 6 replies - 1 through 6 (of 6 total)
  • You should authorise the app to auto publish by click on the authorize/Reauthorize button in the plugin’s settings page,please check your facebook settings and make sure Valid OAuth redirect URI is set as the correct url given as Note in the settings page of Social Media Auto Publish.
    Please go through the documentation.
    If any doubts,please let us know.
    Thanks.

    I did everything as mentioned in the documentation. But when I tried to authorize the page reloads and nothing happens.

    When I check the facebook app there is a change,

    Use Strict Mode for Redirect URIs
    Only allow redirects that use the Facebook SDK or that exactly match the Valid OAuth Redirect URIs. Strongly recommended.

    So is these things are already handled by the plugin ?

    Yes,there is changes, that’s why i said “make sure Valid OAuth redirect URI is set as the correct url given as Note in the settings page of Social Media Auto Publish”.And the documentation is updated with the OAuth Redirect URI change.
    If the page just reloads when click on the authorize/reauthorize button,un-comment the //ob_start(); in social-media-auto-publish.php(line number 32) or enable output buffering as a temporary fix,and disable it after authorisation.
    Hope it helps.
    Thank you.

    Do you have any idea about site url thing?

    my site hosted in sub folder of my site (www.example.com/wp), but in the social media auto publish settings page the url show like this http://www.example.com.

    Is that ok ? When I check with another plugin they are suggesting to put http://www.example.com/wp url.

    yes,
    In your Facebook app settings at https://developers.facebook.com/apps ,You should set the site url as : http://www.example.com
    And then navigate to Apps > Facebook Login > Settings. Set the Valid OAuth redirect URIs as :
    http://example.com/wp/wp-admin/admin.php?page=social-media-auto-publish-settings&auth=1

    Hope it helps.

    I just uncommented ob_start() functions and everything looks ok.
    But as per your recent comment In facebook apps, for the site URL you should put http://www.example.com/wp instead of http://www.example.com/

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Facebook Authorization issues’ is closed to new replies.