Support » Plugin: NextScripts: Social Networks Auto-Poster » Facebook attachment not appearing and text truncated

  • Resolved viveramedia

    (@viveramedia)


    I am trying to post to a Facebook group and Page.

    I can do so successfully but the following issues occur:

    Attachment to WordPress post – the test post works fine, but when posting a custom post type to Facebook, no attachment is visible – I have tried every combination of post type and all are the same.

    Also the last 2 lines of the post (using format %FULLTEXT%) is not appearing in the facebook post.

    I am using 3.1.2 (API Version: 2.11.5) [Pro – Multiple Accounts Edition]

    http://wordpress.org/plugins/social-networks-auto-poster-facebook-twitter-g/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author NextScripts

    (@nextscripts)

    >> custom post type

    Does it work if you use the regular WordPress posts?

    Yes, it appears to work fine with the standard post type. Is there any way I can ensure a custom post type works the same? I’ve ensured all og tags are present, but it still doesn’t show the attachment and misses off 2 lines of text.

    Thanks,

    Dave

    Plugin Author NextScripts

    (@nextscripts)

    Well, you need to take a look at whatever added your custom post type or whatever processes it.

    What am I looking for? I.e what does the post type require for it to work as it should? I’m using the Types plugin.

    And can you let me know what files I need to be looking in that creates the Facebook post? That would be a great help, Thanks

    Hi, can you help me?

    Plugin Author NextScripts

    (@nextscripts)

    All Facebook functions are in the /wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/inc-cl/fb.php, but I doubt your problem has anything to do with that. You need to look at whatever process your post BEFORE it gets to SNAP. Something is alerting the link and text of your post.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Facebook attachment not appearing and text truncated’ is closed to new replies.