WordPress.org

Support

Support » Plugins and Hacks » Facebook API came back with a faulty result…

Facebook API came back with a faulty result…

Viewing 15 replies - 1 through 15 (of 20 total)
  • The same exact thing is happening to me; I made sure everything was updated (theme, plug-in, etc) and that the FB albums were public. Help!

    Plugin Author mglaman

    @mglaman

    I’m revisiting the plugin. Facebook’s API may have changed and I’m investigating.

    In short: I’ll see if I can figure something out! The plugin is getting new life.

    I’m having the exact same problem. it was working a month ago and now i get that error and message

    Same problem here. The odd thing is that the plugin is working on one of my sites, and broken on another. (It was working 1 week ago, and between then and now I have made 0 changes to the site)

    I’ve combed through my facebook page’s settings and found no privacy restrictions.

    Any advice on how to fix this problem would be greatly appreciated.

    Plugin Author mglaman

    @mglaman

    Hey all, so people seem to have gotten this fixed by integrating the plugin with a Facebook App.

    I don’t know if Facebook is cracking down on unauthenticated API requests from IPs or what’s up.

    The 3.x release is in /trunk and in somewhat development. This project doesn’t pay the bills and never has, so it is on the backburner of my list of projects. But it if did pay some bills, then there’d probably be more work.

    Someone solved the problem? I cant find a solution for it 🙁

    Same problem here… some guy on another thread suggested this:

    https://wordpress.org/support/topic/widget-not-working-heres-fix?replies=1

    Still not working for me… but maybe someone else will be luckier?

    The error I am getting is:

    Please try entering https://graph.facebook.com/10152487369916096&type=1/photos?fields=source,link,name,images,album&limit=6 into your URL bar and seeing if the page loads.Facebook API came back with a faulty result. You may be accessing an album you do not have permissions to access.

    Following the instructions, it displays the following:

    {
       "error": {
          "message": "(#803) Some of the aliases you requested do not exist: 10152487369916096&type=1",
          "type": "OAuthException",
          "code": 803
       }
    }

    The album is public / in a public group, and creating a Facebook App and adding its login details to the plugin will simply make the error message displayed on the website change to:

    OAuthException: (#803) Some of the aliases you requested do not exist: 10152487369916096&type=1Sorry, there was an error loading the Facebook album, please refresh the page and try again.

    Hi, first sorry for my English, or rather, pardon the Google Translate English 😉
    I have the same problem.
    But if I delete the cache in Settings/Facebook Album: Clear all caches returns to work, but … just once!

    Reload the page and … does not work!

    I no programming, but still helps if you know someone who programming.

    Sorry again for the Google Translate English…

    Hi,
    you can solve it by create new app in facebook and get the App ID and App Secret. put it into to the settings->facebook album APP ID and App Secret in you’r wordpress site.

    I did that and now I`m getting a blank page…

    There is a fix!

    First, I tried the link Angela shared (https://wordpress.org/support/topic/widget-not-working-heres-fix?replies=1) — it didn’t work for me.

    SOLUTION:
    Creating an app and then placing the ‘App ID’ and ‘App Secret’ into Settings > Facebook Album > General Settings

    Go to FB, login, and go to apps:
    https://developers.facebook.com/

    Create an app, enter a name like “wp plugin” and go to last step to see the App ID and App Secret.

    Hope that helps 🙂

    Hi,
    I encounter the same problem, e.g. at http://test.blinireizen.nl/reizen/info-india/ (2 messages, 1 at the top and 1 in left menu-bar).

    I tried to follow the advice from Zingseven above (creating an app etc.)
    I have created a new app in Facebook via https://developers.facebook.com/, named ‘wp plugin” and I have the App ID and the App Secret.

    Now I am not sure what to do next. Do I go to my WordPress-account and edit the Facebook-albums-plugin? And where do I have to enter the App ID and App Secret?

    Tnanks for your help!

    @blinireizen, you just need to login to your WP Dashboard and then go to the plugin’s settings.

    In the dashboard, look on the left navigation, hover over “Settings” and then click “Facebook Album”…

    Under “General Settings”, you will see an area to enter your App ID and App Secret.

    Hope that helps 🙂

    @zingseven, thanks, it worked!!

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Facebook API came back with a faulty result…’ is closed to new replies.