Support » Plugin: Revive Old Posts - Auto Post to Social Media » facebok and the new update 8.0.3

  • Resolved xac1909

    (@xac1909)


    Hi

    Today, I upgrade the plugin revive old post from 7.4.8 to 8.0.3, everything went wrong, since then I can not post on my Facebook fan page, I always was asked for https on my page (my blog doesn’t have https) and When you authorized the application, post on my wall, not on my fan page, and there is no option to change it. By mistake, I deleted the application and with it was eliminated all the publication made by revive old post on my fan page. I had to go back to the version 7.4.8 and lost 80% of the post in my fan page. Please solve soon this big issue, the plugin had worked well for almost 4 years but today went just simply a nightmare.

    • This topic was modified 1 year, 2 months ago by  xac1909.
    • This topic was modified 1 year, 2 months ago by  xac1909.
    • This topic was modified 1 year, 2 months ago by  xac1909.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • same here.

    Plugin Contributor rsocial

    (@rsocial)

    Hey @xac1909 and @scottish-tourist,

    Can you contact us at https://revive.social as I would need to have a closer look and check what’s happening?

    Thanks!

    Plugin Contributor Uriahs Victor

    (@uriahs-victor)

    In addition to the comment above, please note that recent facebook policies do require that your website have HTTPS to be able to create a facebook application and only older apps allow non HTTPS websites to create apps.

    Hi,
    Oh, thank you for that information, I didn’t know, so, that was the problem trying to create a new app.

    Well for the moment the only thing that i can do is stay in the version 7.4.8, thanks for your help.

    • This reply was modified 1 year, 2 months ago by  xac1909.
    Plugin Contributor Uriahs Victor

    (@uriahs-victor)

    Facebook will eventually retire the old API and you’d be forced to move up to a newer API which would need HTTPS, you should start thinking about this as there’s going to be many more downsides to not having HTTPS on a website.

    Hi,

    I already updated my site to HTTPS, but the error keep continue “Unable to share post for facebook. Error: (#200) Requires either publish_actions permission, or manage_pages and publish_pages as an admin with sufficient administrative permission”

    I will appreciate your help

    UPDATE: I don’t know what i did, but the problem is solved 😉

    we found facebook change the permission requirements for posting to pages from just manage_pages to require both manage_pages and publish_pages. by granting both permissions we solved our problem

    in essence we had to pass the client to https://www.facebook.com/dialog/oauth?client_id=client_id&redirect_uri=redirect_uri&scope=manage_pages,publish_pages&response_type=code%20token&enable_profile_selector=1&profile_selector_ids=pageid

    Plugin Contributor Uriahs Victor

    (@uriahs-victor)

    @nvanesch that’s strange, I checked the URL being sent to facebook by the plugin and it already has the manage_pages and publish_pages scope in the URL, it also had the email scope

    Can you please send us a ticket here so we can look into your environment a bit more?
    https://revive.social/contact

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘facebok and the new update 8.0.3’ is closed to new replies.