WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Facebbook Thumbnails not shown

[Resolved] Facebbook Thumbnails not shown

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author JS Morisset

    @jsmoriss

    You’ll have to turn on debug mode (in the Advanced settings page), so I can see what’s going on…

    Thanks,

    js.

    Plugin Author JS Morisset

    @jsmoriss

    I had a quick peak at your HTML code, and from what I can see, it looks like you’re using straight <img/> tags in your code. And those <img/> tags don’t have any width or height info. NGFB is probably un-able to use those images because it doesn’t know if they’re too small — no way to know if they’re tiny thumbnails or not. If you include width and height info, that would probably fix the issue.

    On the Advanced settings page, you could also un-check “Ignore Small Images”. This should be fine, provided you don’t use any thumbnails in your content. 😉

    js.

    Thank You for the quick response.

    1 ) “Ignore Small Images” was already unchecked
    2 ) “Debug mode” is on now
    3 ) For us, it’s just more work without sense to use “width or height” for each picture, because they are exacrly fitted in Potoshop before. On the other hand, there is no problem if we don’t use NGFP.

    Plugin Author JS Morisset

    @jsmoriss

    You might want to double-check that ‘Ignore Small Images’ option.

    You can also add the following to your wp-config.php file:

    define('NGFB_MIN_IMG_SIZE_DISABLE', true);

    As I said earlier, if you don’t use width and height attributes, the following images will also be considered valid:

    [http://www.highendfood.org/de/wp-content/plugins/comprehensive-google-map-plugin/assets/css/images/transparent.png] => 1
    [http://www.highendfood.org/de/wp-content/plugins/comprehensive-google-map-plugin/assets/css/images/directions.png] => 1

    Keep in mind that not using width and height attributes also slows page load times and lowers your google page score / ranking.

    js.

    I checked an un-checked “Ignore Small Images” a few times (and saved the changes), but the Problem keeps the same.

    Then I changed the wp-config.php file an now all the Images are shown in the Facebook object debugger, so thanks for this part of the solution.

    Unfortunately, when i copy the link tho Facebook, there are just 3 thumbnails shown too choose.

    The main target for us is to get the right thumbnails to choose @ Facebook, if we post a link to a new report. It doesn’t matter if there are 2 Images more or lesss, the main thing is to get the possibilty to selct between all the images.

    Plugin Author JS Morisset

    @jsmoriss

    Open Graph documents the webpage for social websites like Facebook. What these websites decide to do with that information is up to them. I see the tags are now showing 20 images. If Facebook is showing only 3 in it’s sharing popup, then it’s not because of the Open Graph headers. Facebook has it’s own guidelines about images — size and aspect ratio — so perhaps some of those images do not fit those guidelines.

    If you want to choose a single custom image for a Post or Page, then you could upgrade to the Pro version, set the Maximum number of images to 1, and choose an image for each Post or Page,

    js.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] Facebbook Thumbnails not shown’ is closed to new replies.