Support » Themes and Templates » F8 Lite Theme stretches thumbnail post images

  • srdx

    (@simonredux)


    I wonder if anyone can help figure this out? I looked but could not see a simple setting fix.

    When I create a post, inserting a .JPG image into the post, I can choose the size of the image ‘Small; Medium; Large; Full size’ and the display is correct within the post itself – however for display on the front page, the F8 Lite Theme decides to *shrink* the image down to 150 x 150 px – and then, *stretch* the image horizontally.

    See my site: http://www.simonredux.com/

    Why would it do that? I have resized the image to every conceivable size that might make the theme adjust it with no artificial stretching, nothing doing!

    I’m slightly mystified why they would enforce this coding stretch on images. Cropping within the settings makes no difference.

    Thanks if you can assist.

Viewing 15 replies - 1 through 15 (of 23 total)
  • srdx

    (@simonredux)

    Anyone?

    This may help.

    Go to Settings->Media

    Uncheck box “Crop thumbnail to exact dimensions” if checked.

    srdx

    (@simonredux)

    Thanks Donald, I had done that. Doesn’t make any difference. If i crop the image and select all three options when in the Media > Library.

    (There in the Thumbnail settings there is a choice of ‘All image sizes’, ‘Thumbnail’, and ‘All sizes except thumbnail’.

    None of these selections, or the ensuing crop itself make any difference to the home page display of the image – this theme still introduces artificial stretching. It is pretty frustrating spending time creating a page – only for a really unpleasant code to ruin it. This is a visual theme, you would expect there to be some ability to control the stretch.

    Looks like I’ll have to scratch this theme and find another, unless there is a way to show a image that hasn’t had it’s pixels stretched. Thanks.

    srdx

    (@simonredux)

    Man this is frustrating, the people that produce the F8 Lite theme do not offer any type of unpaid support, and this forum seems very light, in terms of active problem solvers. I’m dumfounded. Does anyone else have the problem of thumbnail images on posts, being horiontally stretched when displaying on the front page?? Why would they make the code do this?

    I have 2 posts on the front page of http://www.simonredux.com/

    srdx

    (@simonredux)

    Another user had suggested this workaround:

    1) Check that your thumbnail images are 310x150px in size, or are of a size that will squeeze to those dimensions in proportion, ie 620x300px – the thumbnails need to be this size to work.

    On my page http://www.simonredux.com/ I posted a blog about the WWD conference, I used an image of the iPhone 4, and created the thumbnail image to *exactly* 310x150px, when I cropped in the media library tool, it looked great, I saved it…hoping this would be it, went back to my home page and what happened? A stretched version! 100×48 in size.

    Do the theme makers ever respond in these forums?

    I had been having the same problem… I tried this and it seems to be working:

    1) Ensure that your image is 310x150px
    2) Set up your default image and thumbnail sizes: Click Settings – Media and set your thumbnail size to 310px wide by 150px tall. I also unchecked “Crop thumbnail to exact dimensions,” although I’m not sure this does anything.
    3) Set your medium size images to 590px wide. Do not set a height.
    4) Set your large size images to 950px wide. Do not set a height.

    Now give it a try… Hope that works!

    srdx

    (@simonredux)

    cprofilet85 – thank you, actually this helps for 2 of my post thumbnail images, but not for the iphone 4 image. really bizarre.

    graphpaper press were good enough to get back to me with this link: http://demo.graphpaperpress.com/f8-lite/wp-content/themes/f8-lite/instructions.html which pretty much is as your post.

    I downloaded the regenerate thumbnail plugins and have activated it on these 3 images, 2 of which took hold, however every time I try to crop the thumbnail for the iphone image, as soon as I apply the change it defaults from my selected crop – to the full size image….basically it won’t let me crop it! :/

    Sometimes I think it might be worth learning to hand code, just to have full control! It would probably only take marginally longer than tinkering with themes that don’t do what it says on the tin.

    Thanks for your post though 🙂

    Ramzi Komati

    (@ramzikomati)

    Go to and edit the file /html_public/wp-content/themes/f8-lite/home.php

    On the 7th line you should find the following code:

    <?php get_the_image( array( 'custom_key' => array( 'thumbnail' ), 'default_size' => 'thumbnail', 'width' => '310', 'height' => '150' ) ); ?>

    Replace thumbnail with post-thumbnail, you should have something like this:

    <?php get_the_image( array( 'custom_key' => array( 'post-thumbnail' ), 'default_size' => 'post-thumbnail', 'width' => '310', 'height' => '150' ) ); ?>

    Problem solved for new post and old post entries 🙂 check out artissus.com to see how it works 🙂

    Kind Regards,
    Ramzi Komati

    Ramzi Komati

    (@ramzikomati)

    You can also access /html_public/wp-content/themes/f8-lite/home.php by logging in into your WordPress admin room, go to Appearance > Editor and click on home.php 🙂

    Kind Regards,
    Ramzi Komati

    Thanks, Ramzi Komati!! I just started using F8 Lite and came upon this dilemma. Your solution worked like a charm and instantly. Thank you again for sharing!

    Thanks Ramzi! This solution helped to make my thumbnail images look less stretched.

    I’ve noticed that the images look a bit off. Could you check it out and tell me if I’m just going crazy or not? http://www.blog.lovesongphoto.com.

    They do look better than they did before I implemented your code…

    Thanks!!

    Krista

    You are both welcome, I’m glad it worked well.

    Concerning your case, Krista, it is perfectly normal to lose a bit of your image (more precisely the top and bottom of your image) and I don’t see your images being stretched at all.

    Explication:
    The post-thumbnail resize the image by its width to 310px without changing the original image ratio (preventing it to stretch or squash). The image is than cropped from its middle to 310x150px, that’s what causes you to loose a bit of your image.

    Kind regards,
    Ramzi Komati

    Thank you for this! Very helpful!

    I have another question along the same line.

    1)How can I prevent the featured image in the header to stretch?
    I know I can choose single image header, but I like the slideshow.

    2) Also, is there a way of reviewing which images you have set as featured image?

    Thanks again!

    Best regards,
    Marte

    WordPress doesn’t resize your image to 950×425. You should hire a programmer to do that.

    If you want to feature certain pictures on other. I recommend you to create a new post category (let’s call it featured), and assign it as a secondary category on posts you want to add in the featured box.

    Than go to Post > Categories and click on featured. Check out the link in your browser address bar you should find something like that:

    http://www.artissus.com/wp-admin/edit-tags.php?action=edit&taxonomy=category&tag_ID=5&post_type=post

    Notice tag_ID=5, it means your category ID is 5.

    Now go to Appearance > Theme Options, and write down in the Slideshow Categories the category ID of the features category (in our case it’s 5).

    Kind regards,
    Ramzi Komati

    Hi,

    I seem to have both problems. Images won’t resize, and they slideshow doesn’t work!

    Ramzi, regarding the slideshow, I followed your instructions, the standard ones, and it doesn’t seem to work. It shows no image at all.

    Anyone has any idea on how to make the header slideshow work?

    Thanks a lot for your help!

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘F8 Lite Theme stretches thumbnail post images’ is closed to new replies.