Support » Plugin: Easy Table of Contents » [ez-toc] or [toc] doesn’t display anything

  • Resolved Edward

    (@kamiyeye)


    As the title says, I tried the two shortcodes with no luck, but Auto Insert works. I need shortcode because many articles on my site are short enough that requires no table of contents at all. With a shortcode, I can display a table of contents only needed.

Viewing 1 replies (of 1 total)
  • Plugin Author Steven

    (@shazahm1hotmailcom)

    @kamiyeye

    Navigate to the Settings : Table of Contents admin page and disable the “Auto Insert” on all post types. Note, unchecking the checkbox disables the option. Save the changes.

    Edit the pages where you wish to insert the TOC. Scroll to the Table of Contents metabox on the edit post/page admin screen. Enable the “Insert TOC” option by adding a check to the checkbox. Save the changes.

    Following these steps, the TOC will only be inserted on your chosen pages in desired location dictated by the shortcode.

    The shortcodes simply allow custom placement, overriding the “Position” option on the Settings : Table of Contents admin page.

    Kind regards!

    ps. I do not plan on actively promoting the use of the shortcodes … I’ll let advanced users find them. The reason, in my experience in providing support most users have a difficult time with shortcodes. If/When Gutenberg is merged into the WP core perhaps I’ll look to adding a Gutenberg block to ezTOC.

Viewing 1 replies (of 1 total)
  • The topic ‘[ez-toc] or [toc] doesn’t display anything’ is closed to new replies.