WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Extra tag after include

[Resolved] Extra tag after include

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author redpixelstudios

    @redpixelstudios

    On first review, it doesn’t seem that RPS Include Content is adding a paragraph tag at the end of the included content. However we noticed that the editor in WordPress seems to add an empty paragraph tag at the end if the last item is a block level element.

    One way to help verify the issue is to look at the piece of included content by itself within a rendered theme page to see if the empty paragraph tag appears. If so, then it is not being added by the plugin, but if not, then we have some additional investigation to do.

    Let us know. Thanks.

    With further investigation, the orphaned </p> tag is showing up in somewhat random fashion.

    It does only appear where posts have been included, not on the original posts themselves.

    It doesn’t happen on every included post though (or at least not in every occurrence)

    Most of my included posts are tabular data, a couple end with a link, but both of them show evidence of having the extraneous </p> tag.

    Interestingly enough, this only seems to be a problem when there is more then on piece of data included on a post. I have instances where the same included post invokes the tag on a page with multiple includes, but doesn’t show it when it is the only piece of included data on the page.

    Plugin Author redpixelstudios

    @redpixelstudios

    Understood. We will look into replicating the issue by using more than one include on a page and see what can be determined. Thanks for the detailed information.

    Plugin Author redpixelstudios

    @redpixelstudios

    We did some testing using the twenty thirteen theme and were unable to replicate the issue. Perhaps there is something about the included content that is the cause or maybe another plugin or theme function is also hooking into the_content filter and manipulating the output.

    Plugin Author redpixelstudios

    @redpixelstudios

    We are going to go ahead and close out this support topic. Please feel free to reopen it if you were unable to resolve the issue and you feel the issue is caused by RPS Include Content. Thanks.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Extra tag after include’ is closed to new replies.