• Hi There,

    I am working on a clients website and we are using the kadence blocks for the tabs block.

    I have noticed that when I add any extra tabs apart from the default 3 when the block is created that I cannot add any blocks to them, I also cannot remove the tab title from the list of tabs, when I click the X I get a console error.

    I have updated the plugin and have the latest wordpress version.
    Tried new pages with only this block on them with no luck, only the original 3 tabs are usable.

    Working Tab [IMG]
    Non Working Tab [IMG]
    Console Error [IMG]

    • This topic was modified 1 month, 2 weeks ago by johnsc. Reason: Updating img links
Viewing 3 replies - 1 through 3 (of 3 total)
  • Hey,
    I just tested locally and can’t recreate that. Can you tell me have you tried deactivating other plugins?

    Ben

    Thread Starter johnsc

    (@johnsc)

    Hi Ben,

    Thanks for your reply.

    I did try deactivating plugins and things, but couldn’t get it to work.

    However, we are using the “allowed_block_types” filter to restrict the site to only use particular blocks. I noticed when I disable this filter (allowing all blocks) that the tabs block works as expected.

    I had added the “kadence/tabs” only to the whitelist, so I tried adding all the other kadence blocks just to test if there was some cross dependencies on them, but this still didnt get it working.

    So my only option at the moment is to turn off the filter/whitelist and allow all blocks for use.

    Any idea what might be causing the issue here with the tabs block? Does it have a dependency on any other blocks or core blocks?

    Ill continue looking into it once I get this delivered to the client.

    Cheers,
    John

    Hey John,
    The Kadence Tabs block also requires the kadence/tab block. There is a tabs block which controls the controls and a nested inner block called kadence/tab.

    Ben

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.