Support » Plugin: WordPress Popular Posts » Extra span being printed

  • Resolved jonnyrefined

    (@jonnyrefined)


    Hi there,

    Love the plugin is easy to use. Just having this one problem that is causing my list of links to not be aligned properly if they wrap onto a second line.

    I’m using this in a category page to show the top links by category

    if (function_exists('wpp_get_mostpopular')) {
        wpp_get_mostpopular(array(
            'limit' => 6,
            'cat' => $catID,
            'stats_views' => 0
        ));
    }

    Even though I’ve turned off the stats_views it’s still printing in the HTML:
    <span class="wpp-meta post-stats"></span>

    Could you help with this at all? I’ve tried display none but the span is still causing the list spacing to shift slightly.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Héctor Cabrera

    (@hcabrera)

    Hi @jonnyrefined,

    Can you please share your site’s URL so I can see the span/shifting issue?

    Thread Starter jonnyrefined

    (@jonnyrefined)

    Hi Hector,

    thanks for the fast response, is there any way for me to privately share the link to the site with you?

    Thanks

    Plugin Author Héctor Cabrera

    (@hcabrera)

    Yes, you can use my contact form to send me an email with your site’s URL.

    Thread Starter jonnyrefined

    (@jonnyrefined)

    Hi Hector,

    I’ve sent you a message through the contact form thanks for the help 🙂

    Plugin Author Héctor Cabrera

    (@hcabrera)

    Got it, thanks Jonny.

    Alright, I checked your website and I’m not sure that the issue is being caused by the span tag. I removed it from the page using the console and the shifting was still there.

    So instead I played around with the CSS rules and with these the spacing between the bullet and the post title is now consistent:

    .wpp-list li::before {
        display: none;
    }
    
    .wpp-list li {
        padding-left: 1em;
        margin-top: 0.5em;
        margin-left: 0.25em;
        transition: text-shadow 0.3s;
        cursor: pointer;
        background: url(/wp-content/themes/caj/assets/svg/svg-desktop/arrow.svg) left 0.35em no-repeat;
        background-size: 0.5em;
    }

    Give that a shot and report back your results.

    Thread Starter jonnyrefined

    (@jonnyrefined)

    Perfect that has fixed it. Thanks for the help!

    Plugin Author Héctor Cabrera

    (@hcabrera)

    Don’t mention it, glad I could help!

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.