Support » Plugin: Jetpack by WordPress.com » Extra Sidebar Widgets not working

  • Resolved davidebabylonia

    (@davidebabylonia)


    Hi, I have the latest version of this plugin but still im unable to activate the extra widgets, whenever I click to activate I get “Extra Sidebar Widgets failed to activate. SyntaxError: Unexpected token < in JSON at position 0”

    How can I fix this?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Could you let me know what other plugins are currently active on your site?

    Could you also try the following:

    1. Open the dashboard page.
    2. Open your browser console
    3. Click on the Network tab
    4. Refresh the page.
    5. Try to activate a module
    6. If you see any lines in red inside the browser console, click on them. A new panel should appear on the right.
    7. Click on the “Response” tab in that new panel.
    8. Copy the message displayed there.
    9. Paste it here.
    10. If no red lines appeared in the browser console, click on the “Console” tab of the browser console.
    11. Copy any errors displayed there, and paste them here.

    Thanks!

    Dear Jeremy, wordpress support system does not allow me to paste the content of the console, where can I contact you?

    It seems that the plugin is searching for some file in root folder of the site, but my wordpress installation is in a subfolder

    ie:

    http://www.cookingwithpeachy.com/wp-json/jetpack/v4/settings/ 404 (Not Found)
    http://www.cookingwithpeachy.com/wp-json/jetpack/v4/site/ 404 (Not Found)
    http://www.cookingwithpeachy.com/wp-json/jetpack/v4/connection/url/ 404 (Not Found)

    My root folder is http://www.cookingwithpeachy.com/wordpress/

    This is what I get

    admin.js?ver=4.4.1:9 GET http://www.cookingwithpeachy.com/wp-json/jetpack/v4/connection/url/ 404 (Not Found)fetchConnectUrl @ admin.js?ver=4.4.1:9(anonymous function) @ admin.js?ver=4.4.1:19(anonymous function) @ admin.js?ver=4.4.1:8(anonymous function) @ admin.js?ver=4.4.1:5value @ admin.js?ver=4.4.1:24mountComponent @ admin.js?ver=4.4.1:2mountComponent @ admin.js?ver=4.4.1:2mountComponent @ admin.js?ver=4.4.1:2mountComponent @ admin.js?ver=4.4.1:2mountChildren @ admin.js?ver=4.4.1:4_createContentMarkup @ admin.js?ver=4.4.1:3mountComponent @ admin.js?ver=4.4.1:3mountComponent @ admin.js?ver=4.4.1:2mountComponent @ admin.js?ver=4.4.1:2mountComponent @ admin.js?ver=4.4.1:2mountComponent @ admin.js?ver=4.4.1:2mountComponent @ admin.js?ver=4.4.1:2mountChildren @ admin.js?ver=4.4.1:4_createContentMarkup @ admin.js?ver=4.4.1:3mountComponent @ admin.js?ver=4.4.1:3mountComponent @ admin.js?ver=4.4.1:2mountChildren @ admin.js?ver=4.4.1:4_createContentMarkup @ admin.js?ver=4.4.1:3mountComponent @ admin.js?ver=4.4.1:3mountComponent @ admin.js?ver=4.4.1:2mountComponent @ admin.js?ver=4.4.1:2mountComponent @ admin.js?ver=4.4.1:2mountComponent @ admin.js?ver=4.4.1:2mountComponent @ admin.js?ver=4.4.1:2mountComponent @ admin.js?ver=4.4.1:2mountComponent @ admin.js?ver=4.4.1:2mountComponent @ admin.js?ver=4.4.1:2mountComponent @ admin.js?ver=4.4.1:2mountComponent @ admin.js?ver=4.4.1:2mountComponent @ admin.js?ver=4.4.1:2mountComponent @ admin.js?ver=4.4.1:2mountComponent @ admin.js?ver=4.4.1:2mountChildren @ admin.js?ver=4.4.1:4_createContentMarkup @ admin.js?ver=4.4.1:3mountComponent @ admin.js?ver=4.4.1:3mountComponent @ admin.js?ver=4.4.1:2mountComponent @ admin.js?ver=4.4.1:2mountComponent @ admin.js?ver=4.4.1:2m @ admin.js?ver=4.4.1:1perform @ admin.js?ver=4.4.1:2M @ admin.js?ver=4.4.1:1perform @ admin.js?ver=4.4.1:2batchedUpdates @ admin.js?ver=4.4.1:3o @ admin.js?ver=4.4.1:2_renderNewRootComponent @ admin.js?ver=4.4.1:1_renderSubtreeIntoContainer @ admin.js?ver=4.4.1:1render @ admin.js?ver=4.4.1:1a @ admin.js?ver=4.4.1:1(anonymous function) @ admin.js?ver=4.4.1:1t @ admin.js?ver=4.4.1:1(anonymous function) @ admin.js?ver=4.4.1:1(anonymous function) @ admin.js?ver=4.4.1:1
    admin.js?ver=4.4.1:9 GET http://www.cookingwithpeachy.com/wp-json/jetpack/v4/site/ 404 (Not Found)fetchSiteData @ admin.js?ver=4.4.1:9(anonymous function) @ admin.js?ver=4.4.1:19(anonymous function) @ admin.js?ver=4.4.1:8fetchSiteData @ admin.js?ver=4.4.1:29componentDidMount @ admin.js?ver=4.4.1:29notifyAll @ admin.js?ver=4.4.1:2close @ admin.js?ver=4.4.1:4closeAll @ admin.js?ver=4.4.1:2perform @ admin.js?ver=4.4.1:2M @ admin.js?ver=4.4.1:1perform @ admin.js?ver=4.4.1:2batchedUpdates @ admin.js?ver=4.4.1:3o @ admin.js?ver=4.4.1:2_renderNewRootComponent @ admin.js?ver=4.4.1:1_renderSubtreeIntoContainer @ admin.js?ver=4.4.1:1render @ admin.js?ver=4.4.1:1a @ admin.js?ver=4.4.1:1(anonymous function) @ admin.js?ver=4.4.1:1t @ admin.js?ver=4.4.1:1(anonymous function) @ admin.js?ver=4.4.1:1(anonymous function) @ admin.js?ver=4.4.1:1
    admin.js?ver=4.4.1:9 GET http://www.cookingwithpeachy.com/wp-json/jetpack/v4/settings/ 404 (Not Found)fetchSettings @ admin.js?ver=4.4.1:9(anonymous function) @ admin.js?ver=4.4.1:19(anonymous function) @ admin.js?ver=4.4.1:8fetchSettings @ admin.js?ver=4.4.1:31componentDidMount @ admin.js?ver=4.4.1:31notifyAll @ admin.js?ver=4.4.1:2close @ admin.js?ver=4.4.1:4closeAll @ admin.js?ver=4.4.1:2perform @ admin.js?ver=4.4.1:2M @ admin.js?ver=4.4.1:1perform @ admin.js?ver=4.4.1:2batchedUpdates @ admin.js?ver=4.4.1:3o @ admin.js?ver=4.4.1:2_renderNewRootComponent @ admin.js?ver=4.4.1:1_renderSubtreeIntoContainer @ admin.js?ver=4.4.1:1render @ admin.js?ver=4.4.1:1a @ admin.js?ver=4.4.1:1(anonymous function) @ admin.js?ver=4.4.1:1t @ admin.js?ver=4.4.1:1(anonymous function) @ admin.js?ver=4.4.1:1(anonymous function) @ admin.js?ver=4.4.1:1
    admin.js?ver=4.4.1:9 GET http://www.cookingwithpeachy.com/wp-json/jetpack/v4/settings/ 404 (Not Found)
    • This reply was modified 2 years, 7 months ago by  Steve Stern. Reason: put code in backticks
    Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    Your large pastes are getting caught in the spam filters. Please use a pasting service like pastebin.com or gist.github.com to paste your content, then paste the link here.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    It seems that the plugin is searching for some file in root folder of the site, but my wordpress installation is in a subfolder

    Could you tell me more about your site setup? When going to your site, I’m redirected to http://www.cookingwithpeachy.com/wordpress/

    What are the 2 different URLs you’ve set under Settings > General in your dashboard?

    It’s also worth noting that your site’s XML-RPC file, that Jetpack uses to communicate with WordPress.com, is inaccessible right now:
    http://www.cookingwithpeachy.com/wordpress/xmlrpc.php

    If you use a security plugin to block access to the file, you’ll need to configure it to allow incoming and outgoing connections to /xmlrpc.php.

    If you do not use such plugin, you’ll want to contact your hosting provider and ask them if they currently block access to your site’s XML-RPC file.

    I hope this helps.

    Thank you for the instruction on how to paste the data, here the link: http://pastebin.com/TQb1k5dE

    The redirection is right, both fields site and wordpress installation address are http://www.cookingwithpeachy.com/wordpress without the last trailing slash

    About XML-RPC, there was a protection (now removed) in my .htaccess, no matter this, I still have same errors from jetpack

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Could you try to deactivate each one of your plugins, one at a time, and let me know if you find a plugin that appears to be conflicting with Jetpack and stopping you from enabling modules?

    Thanks!

    Hi Jeremy,

    COMET CACHE PRO it’s the problem, after deactivating, the widget module can be activated with no errors

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Excellent! Could you get in touch with the plugin authors and ask them to take a look and make sure their plugin is compatible with the WP REST API, that will be included in all WordPress installations in a few weeks, with WordPress 4.7:
    https://make.wordpress.org/core/2016/10/13/merge-proposal-discussion-rest-api-content-endpoints/

    Once their plugin is compatible, you should be able to activate it again.

    Thanks for the heads up on this thread. I’m one of the Comet Cache developers and we are opening an issue about this so we can investigate and find the underlying cause: https://github.com/websharks/comet-cache/issues/855

    • This reply was modified 2 years, 7 months ago by  JasWSInc.
    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    @jaswsinc Thanks for jumping in! I’ll reply in the GitHub issue with all the info I gathered from this thread. Hopefully this can help you!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Extra Sidebar Widgets not working’ is closed to new replies.