WordPress.org

Forums

Extra line-breaks when posting by e-mail (3 posts)

  1. bxojr
    Member
    Posted 8 years ago #

    Posts sent by e-mail are showing up with extra line breaks inserted, presumably wherever the e-mail client wrapped a line. I've seen this problem reported by others (http://wordpress.org/support/topic/115892) but haven't been able to find any solution. Not sure whether this has been addressed in 2.2.

    I'm sure a lot of people are using the post by e-mail feature, presumably without this problem ... what's going on?

  2. Josh Lewis
    Member
    Posted 7 years ago #

    I'm having this problem in WordPress 2.5, too.

  3. shakewell
    Member
    Posted 7 years ago #

    Here's how I fixed the line breaks:

    I used the Text Control plugin:
    http://dev.wp-plugins.org/wiki/TextControl
    Install the plugin package into WordPress.

    You will now find text control config in your WordPress SETTINGS

    Within text control config, change the default post setting to MARKDOWN

    If you have PHP v. 5x, you will need to replace the markdown.php file with an updated version. Otherwise, you will get errors on every post about Warning: preg_replace_callback()

    Here is the updated version of markdown.php:
    http://michelf.com/projects/php-markdown/

Topic Closed

This topic has been closed to new replies.

About this Topic