Support » Plugin: RSVPMaker » Extra guests broken

  • Resolved Robert

    (@robertlindeboom)


    I installed this plugin and clicked around to set it up. Somehow the functionality with extra guests doesn’t work anymore. That means: it doesn’t register the guests in the counter (not in the confirmation mail too) and also the ‘add guest’ button doesn’t add any fields. I already deleted the form entirely and had the plugin set a new default one, but it still didn’t help. Any ideas? Or will it help if I removed the plugin and reinstalled it? Or is there a safe and easy way to reset it in database? Any help would be great! Thanks in advance!

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Thread Starter Robert

    (@robertlindeboom)

    The HTML content of the form field is the same as the one working on another test environment:

    <!-- wp:rsvpmaker/formfield {"label":"First Name","slug":"first","guestform":true,"sluglocked":true,"required":"required"} /-->
    <!-- wp:rsvpmaker/formfield {"label":"Last Name","slug":"last","guestform":true,"sluglocked":true,"required":"required"} /-->
    <!-- wp:rsvpmaker/formfield {"label":"Email","slug":"email","sluglocked":true,"required":"required"} /-->
    <!-- wp:rsvpmaker/formfield {"label":"Phone","slug":"phone"} /-->
    <!-- wp:rsvpmaker/formselect {"label":"Phone Type","slug":"phone_type","choicearray":["Mobile Phone","Home Phone","Work Phone"]} /-->
    <!-- wp:rsvpmaker/guests -->
    <div class="wp-block-rsvpmaker-guests"><!-- wp:paragraph -->
    <p></p>
    <!-- /wp:paragraph --></div>
    <!-- /wp:rsvpmaker/guests -->
    <!-- wp:rsvpmaker/formnote /-->

    I also tried uninstalling the plugin, deleting it and reinstalling, delete the post types made by RSVPmaker, etcetera.

    Plugin Author davidfcarr

    (@davidfcarr)

    Looks like JQuery is not being enqueued properly, if that tells you anything. Could be an issue with another plugin in the environment, or maybe caching / minimizing of JavaScript causing issues.

    Thread Starter Robert

    (@robertlindeboom)

    Thank you very much for pointing me in this direction. I thought it had something to do with my settings, because I was ‘playing around’. I just saw there was a JQuery error in the browser’s console. Didn’t think about this. It was Autoptimize that was conflicting. I disabled it and now it works again. Thanks for the help and for the plugin. Comes in handy in times of covid-19.

    Thread Starter Robert

    (@robertlindeboom)

    Sorry, one more question. In Adminimize I can exclude scripts from minimizing. Can you tell me the names of the relevant scripts?

    Plugin Author davidfcarr

    (@davidfcarr)

    As far as I can tell, it was the JQuery library bundled with WordPress that wasn’t loading properly. There’s some plugin code that specifies jquery should load on the front end (which is not true by default) in the file script.php.

    Standard function: wp_enqueue_script(‘jquery’);

    Optimizing Matters

    (@optimizingmatters)

    jQuery in general is better left excluded from Autoptimize JS optimization, which is why by default js/jquery/jquery.js is in the comma-separated exclusion list.

    Thread Starter Robert

    (@robertlindeboom)

    Thanks! It was not in my exclusion list (anymore?). I added it, but for now I’ll have JS optimization off.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Extra guests broken’ is closed to new replies.