Support » Plugin: WP EasyPay - Square for WordPress » Extra Fields setup disappears

  • Resolved zmmccrocklin

    (@zmmccrocklin)


    I need some help with the setup. I just purchased the Lifetime Starter package and am having issues with the new form. I had been using the free version for a while, and now that I purchased a license, I’m having issues with customization.

    First, I can’t change the default extra fields. I would like to remove the required flag, but they’re not editable.

    Second, once I submit the extra fields & leave the form settings page, when I go back to make more changes, there is nothing inside the extra fields section. It’s still showing on the site, but there is no control panel to edit my extra fields. I can’t even redo it because the fields pane on the right side doesn’t even show up.

    Tech Details:
    ————

    OS: Fedora 31
    Browser: Google Chrome Version 83.0.4103.97 (Official Build) (64-bit)
    WP: 5.4.2
    Active Theme: Customizr 4.1.52
    WP_DEBUG: Disabled
    WP Memory Limit: 40MB

    ———— NIMBLE CONFIGURATION
    Version: 2.1.0
    Upgraded From: 2.0.15
    Started With: 1.10.7

    ———— WP ACTIVE PLUGINS
    All-in-One Event Calendar by Time.ly: 2.6.4
    Classic Editor: 1.5
    Embed Plus for YouTube – Gallery, Channel, Playlist, Live Stream: 13.4
    Envira Gallery Lite: 1.7.8.9
    Jetpack by WordPress.com: 8.6.1
    Nimble Page Builder: 2.1.0
    WP Easy Pay (Premium): 3.1.3
    WPForms Lite: 1.6.0.2
    WP Maintenance Mode: 2.2.4
    YouTube Live: 1.7.15

    ———— WEBSERVER CONFIG
    PHP Version: 7.4.7
    MySQL Version: 8.0.17
    Webserver Info: Apache/2.4.37 (centos8) OpenSSL/1.1.1c
    Writing Permissions: OK

    ———— PHP CONFIG
    Memory Limit: 256M
    Upload Max Size: 50M
    Post Max Size: 75M
    Upload Max Filesize: 50M
    Time Limit: 30
    Max Input Vars: 1000

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 16 total)
  • Thread Starter zmmccrocklin

    (@zmmccrocklin)

    Just a notice that I can work around the issue by creating a new form, but it creates issue for me if I have to create a brand new form any time I need to edit my fields. Once I save it, the extra fields are gone.

    Hi @zmmccrocklin,
    Thank you for contacting us,
    You can change default fields as these are mandatory fields for a transaction.
    also if you are dragging and dropping extra fields into a form you have to press the save button also there is an edit option on each extra field top right where you can see the extra field control panel if you still have any issue please share the screenshots so we can look into it for you.

    Thanks!

    Hi @zmmccrocklin,
    There was a type error in the first line of above reply you can’t edit the default fields as these are the mandatory fields for the Transaction.

    Thread Starter zmmccrocklin

    (@zmmccrocklin)

    Here’s a video that describes what I mean:

    Thread Starter zmmccrocklin

    (@zmmccrocklin)

    You can probably skip to the last minute if you don’t want to see some of the setup content. In the last minute, I show what happens after I hit the ‘Publish’ button.

    Hi @zmmccrocklin,
    Our technical team needs some info from your end to sort out this issue for you please open a support ticket at our website also please have a look at the screenshot shared below.

    https://prnt.sc/t69cw5

    This ticket is marked as ‘resolved’, but I can’t see any solution. I have exactly the same issue, and I have ‘saved’ and ‘updated’ every time I add a new extra field, then saved and updated again after I have finished.

    When I paste the shortcode into an Elementor shortcode element, the form doesn’t show at all, but when I open the page to view it, it shows just the basic fields and amounts, and when I go back to ‘Extra Fields’ again, the page is completely blank, none of the extra fields are showing and not even the default fields are showing up, or the right hand field options panel.

    Can you share the solution with the rest of us, to save answering the same question over and over again?

    Cheers,
    Terry Chadban

    Thread Starter zmmccrocklin

    (@zmmccrocklin)

    I still haven’t had this resolved. I put in a support ticket, as I was advised, but I have yet to receive a response on it. Due to medical issues I have not been able to follow up. I am following up on it now:

    With the updates, I still encountered the same issues with form creation with extra fields. However, they did the same where I didn’t get any of the extra fields displayed. I had to stick with the one I created before that to have the extra fields.

    With update 3.1.8, It now displays an endless loading screen, no matter which form I use in my shortcode, the original or a newly created form.

    EDIT:
    Here’s some info on what I’m running:
    (Note: I have dnf-automatic setup for automatic system updates, but these are up-to-date as of today)

    
    $ cat /etc/redhat-release
    CentOS Linux release 8.2.2004 (Core) 
    
    $ uname -r
    4.18.0-193.14.2.el8_2.x86_64
    
    ### Begin System Info (Generated 2020-08-15 23:04:01) ###
    ------------ SITE INFO
    Site URL:                 https://gjt-sa.com
    Home URL:                 https://gjt-sa.com
    Multisite:                No
    
    ------------ USER BROWSER
    Platform:                 Linux 
    Browser Name:             Chrome  
    Browser Version:          84.0.4147.105 
    
    ------------ WORDPRESS CONFIG
    WP Version:               5.4.2
    Language:                 en_US
    Permalink Structure:      /%postname%/
    Active Theme:             Customizr 4.2.7
    Show On Front:            page
    Page On Front:            Home (#16)
    Page For Posts:           Unset
    ABSPATH:                  /mnt/cbs/vhosts/gjt-sa.com/public_html/
    WP_DEBUG:                 Disabled
    WP Memory Limit:          40MB
    
    ------------ NIMBLE CONFIGURATION
    Version:                  2.1.5
    Upgraded From:            2.1.1
    Started With:             1.10.7
    
    ------------ WP ACTIVE PLUGINS
    All-in-One Event Calendar by Time.ly: 2.6.7
    Classic Editor: 1.6
    Embed Plus for YouTube - Gallery, Channel, Playlist, Live Stream: 13.4.1
    Envira Gallery Lite: 1.8.0.3
    Nimble Page Builder: 2.1.5
    WP Easy Pay (Premium): 3.1.8
    WPForms Lite: 1.6.2.2
    WP Maintenance Mode: 2.2.4
    YouTube Live: 1.7.16
    
    ------------ WP INACTIVE PLUGINS
    Akismet Anti-Spam: 4.1.6
    Hello Dolly: 1.7.2
    Jetpack by WordPress.com: 8.8.1
    
    ------------ WEBSERVER CONFIG
    PHP Version:              7.4.9
    MySQL Version:            8.0.17
    Webserver Info:           Apache/2.4.37 (centos) OpenSSL/1.1.1c
    Writing Permissions:      OK
    
    ------------ PHP CONFIG
    Memory Limit:             256M
    Upload Max Size:          50M
    Post Max Size:            75M
    Upload Max Filesize:      50M
    Time Limit:               30
    Max Input Vars:           1000
    Display Errors:           N/A
    PHP Arg Separator:        &
    PHP Allow URL File Open:  1
    
    ### End System Info ###
    
    • This reply was modified 2 years, 1 month ago by zmmccrocklin.
    • This reply was modified 2 years, 1 month ago by zmmccrocklin.
    • This reply was modified 2 years, 1 month ago by zmmccrocklin. Reason: added system config info
    • This reply was modified 2 years, 1 month ago by zmmccrocklin. Reason: added kernel version

    Yes, we went through the same frustration, their ‘Support’ actually contacted us and we gave them access to the website, but they couldn’t solve the problem so we eventually ‘solved’ the problem by going back to Caldera Forms!

    Thread Starter zmmccrocklin

    (@zmmccrocklin)

    Hmmm. I haven’t tried Caldera Forms. I ended up just reading Square’s dev documentation & am building my own custom form with javascript & PHP using their sample code from github. Going to setup the form as a popup link on its own subdomain.

    • This reply was modified 2 years, 1 month ago by zmmccrocklin.

    We eventually went with Caldera Forms and their Stripe integration, but our client prefers Square, so if you do get it working I would definitely be interested in your solution?

    Cheers,
    Terry

    • This reply was modified 2 years, 1 month ago by razajobjects.
    Plugin Author WPExperts.io

    (@wpexpertsio)

    Dear @zmmccrocklin and @portmaconline ,

    We are sorry for the inconvenience caused by the issue. Kindly, open ticket on our official website with the reference of this thread and we will resolve your issue on priority.

    Thank you for your patience.

    Thread Starter zmmccrocklin

    (@zmmccrocklin)

    Hmmm…Looks like the update to 3.1.9 fixed the display issues, and my new forms show the extra fields as I configured them. However, I’m still having an issue with the extra fields not showing after publishing the form, so I can’t make any edits if I need to, but I can build a new form as a workaround.

    As far as my custom form, I’m still working with Square to find out why I’m getting 500 errors, but you can see it here:

    https://donations.gjt-sa.com/phpsample/

    I built on top of the PHP sample in this git repo:
    https://github.com/square/connect-api-examples

    • This reply was modified 2 years, 1 month ago by zmmccrocklin.
    wpexpertssupportteam

    (@wpexpertssupportteam)

    Hi @zmmccrocklin,
    We are not authorized to provide the support for the PRO plugin here as this platform is used to provide only the support for the free plugins. Please create a support ticket on our official website so we can help you.

    Thanks!

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Extra Fields setup disappears’ is closed to new replies.