Support » Plugin: WooCommerce PDF Invoices & Packing Slips » Extra 0’s in order number

  • Resolved fullscopecreative

    (@fullscopecreative)


    Orders that were placed in the last few days after the recent update have a lot (hundreds or thousands extra). When I checked in the database it shows each with just the appropriate number no extra 0’s. When I disabled the plugin all was fine.

    Any idea what was causing that?

    Chris

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Ewout

    (@pomegranate)

    Hi Chris,
    I’m sorry to hear that. We haven’t made any changes to the functions handling order numbers since the 2.0 update from july last year, so i’m not sure what’s happening on your site.

    A few questions to help zoom in on the root cause:

    • Is this the order number or the invoice number?
    • are these zeros appearing everywhere in WooCommerce or just the invoice?
    • are you using any filters for order numbers that have a link with the invoice numbers?
    • which version did you use before updating
    • Which version of WooCommerce & WP do you use?
    • what number are you looking at in the database?
    • have you set a padding for the invoice number in the settings? Is it an number or multiple 0’s? (Should be an actual number like 3)

    let us know and we’ll do our best to help resolve this issue!

    Ewout

    -Is this the order number or the invoice number? – it is the invoice number
    -are these zeros appearing everywhere in WooCommerce or just the invoice? – just in the invoice number
    -are you using any filters for order numbers that have a link with the invoice numbers? – no
    -which version did you use before updating – 1.6.5
    -Which version of WooCommerce & WP do you use? WP – 4.9.5 and WC – 3.3.5
    -what number are you looking at in the database? The table in the database ‘wcpdf_invoice_number’ has 16 and 1677 for id and order_id fields
    -have you set a padding for the invoice number in the settings? Is it an number or multiple 0’s? (Should be an actual number like 3) – Do you mean in WooCommerce > PDF Invoices and under Documents > invoices? That number is set right now to 2018000….what should that be?

    Plugin Author Ewout

    (@pomegranate)

    Do you mean in WooCommerce > PDF Invoices and under Documents > invoices? That number is set right now to 2018000….what should that be?

    That should be 7 if you want the result to be 2018000167. Right now you have told the plugin to fill the invoice number with 2.018.000 (over 2 million) 0’s…
    If you want the year in the prefix you can enter that in the ‘prefix’ section (if you use [invoice_year] you don’t have to change that every year either).

    Thas hasn’t changed between versions though, so something must have gone haywire in the settings. Did you change this after updating the plugin?

    You will probably need to reset the invoice numbers that already got generated with these settings, you can do this by going into the order, clicking the edit button (pencil) and then save the order (don’t need to change anything, but this will reset the formatted number to your latest settings).

    Hope that helps!

    Ewout

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Extra 0’s in order number’ is closed to new replies.