Support » Plugin: Slimstat Analytics » External links problem

  • Resolved themadproducer

    (@themadproducer)



    Camu…here you go…new topic plus a link to the test page.

    Basically, if I click an external link, Slimstat seems to be interfering unless I disable Slimstat. With methodical testing, here are the exact symptoms and how to reproduce them.

    – WP v4, Slimstat v3.82
    – Plugin Organizer v5.6.3
    – Chrome Browser v39.0.2171.65 m and IE-11 fail
    (Firefox 28 is NOT affected)

    Reproduce-able (90% or more of the times)
    – CLEAR BROWSER CACHE
    – go to the http://mikesqualitybodyworks.com/slimstat/
    – click the yellow NAVIGATE button and wait a few seconds
    – usually you will be redirected to one of the other internal pages
    – click the browser back button
    – click the navigate button and wait….(Nothing happens usually)
    – click it again and you should finally be directed to the external page at google maps
    – subsequent clicks of the Navigate button will work normally
    To recreate the issue, clear the browser cache and repeat the steps above

    Working pages
    The other non test pages on this website work because I have disabled slimstat on a per-page basis using “Plugin Organizer”.

    Note
    I have also tried disabling all other plugins to isolate an incompatibility without success.

    https://wordpress.org/plugins/wp-slimstat/

Viewing 15 replies - 1 through 15 (of 37 total)
  • Plugin Author Jason Crouse

    (@coolmann)

    It looks like a conflict with some other javascript on the page (theme? other plugin?), but it’s hard to tell where the problem is occurring…

    Plugin Author Jason Crouse

    (@coolmann)

    I narrowed down the issue to a jquery adding new links to the page after the page has been loaded. This triggered a bug in our tracker, by shifting the indexes of all the links. We have a new code which should prevent this from happening now. It will be added to v3.8.4. Please test it and let us know if the issue is resolved.

    themadproducer

    (@themadproducer)

    Ok thx much camu.
    I will test and report back.

    Plugin Author Jason Crouse

    (@coolmann)

    If you don’t want to wait, version 3.8.4 is already available on our github repo:

    https://github.com/getusedtoit/wp-slimstat/releases/tag/3.8.4

    themadproducer

    (@themadproducer)

    Well camu, that seems to have done the trick.
    Well done and thank you very much.

    Plugin Author Jason Crouse

    (@coolmann)

    Wow, that’s great news! A vote for Slimstat would be a great way to say thank you 😉

    themadproducer

    (@themadproducer)

    You bet. Thanks again for the prompt diagnostics and resolution.

    Plugin Author Jason Crouse

    (@coolmann)

    Thanks!

    Sorry, but the issue with IE remains (for me) as you still need two clicks (tested with IE 11). I can confirm that the latest Chrome works with the latest 3.8.4. You can check and test this on http://dev.ox.io/documentation/ if you want (all external links). Happy to assist. If you need any additional just give me a ping.

    Plugin Author Jason Crouse

    (@coolmann)

    Found the glitch. We’ll include a fix in version 3.8.5, next week. Thank you for your patience.

    Perfect. Thx and keep up the good work!

    Hey Bishoph and camu,
    Strange, but for me IE11 works fine.
    I tested each time by clearing history to make sure.
    But in any case, we look forward to 3.8.5

    Plugin Author Jason Crouse

    (@coolmann)

    themadproducer, did you test it on his site?

    Camu, I tested bishoph’s external link on the page that he quoted using IE11 and indeed I needed to consistently click twice.

    NOTE: this is not the same issue I was having when I started this topic and I think you know that because now you fixed both issues.

    Also, I did notice that if I right click on the external link, and chose to open in a new tab, then that works.

    Plugin Author Jason Crouse

    (@coolmann)

    bishoph, I am pushing an update here on WP without changing the version number. Which means I cannot update the CDN. In other words, you might need to disable the CDN until version 3.8.5 is out. In the meanwhile, to force an update, use this trick:

    – Go to Plugins > Editor
    – Select WP Slimstat from the dropdown and click SELECT
    – The text area will start with something like

    Plugin Name: WP Slimstat
    Plugin URI: http://wordpress.org/plugins/wp-slimstat/
    Description: The leading web analytics plugin for WordPress
    Version: 3.8.4

    Change the version number to 3.8.3 and save. Then go back to Plugins and refresh until WordPress tells you that a new version is available. Update again and… see how it goes 🙂

    Cheers,
    Camu

Viewing 15 replies - 1 through 15 (of 37 total)
  • The topic ‘External links problem’ is closed to new replies.