Support » Theme: Pen » External Font Issue

  • Resolved waynez777

    (@waynez777)


    Hi htmlpie, thank you for your wonderful theme! Now I am trying to use it for my WordPress blogsite and found a critical issue which needs your help.

    I found my homepage when Pie Theme takes too long to load and realize the theme use some js codes to visit https://use.fontawesome.com which is the root cause. But I don’t know how to disable it. I search all the css and js code but can not find the fontawesome.com related scripts.

    BTW, it will be greatful if you can teach me how to disable the google fonts too. Thanks in advance.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Theme Author htmlpie

    (@htmlpie)

    Hi there,

    Thanks!

    – FontAwesome is not loaded through that site, so it must be one of the plugins of your site.

    – Disabling Google Fonts is easy, go to Appearance -> Customize -> Typography and change all the Font Family options to “Default”.

    Thread Starter waynez777

    (@waynez777)

    I tried to disable all the plugins and just keep the theme and related pen plugin active but the homepage still loads the FontAwesome.com. I found the Pen Theme has a assets/fonts/fontawesome folder so I think I have to find it within the theme scripts.

    Thread Starter waynez777

    (@waynez777)

    Problem sloved! You are right. The external data requests are controlled by some scripts from NextGen Gallery plugin. Thanks a lot for your tips to narrow down my analysis.

    FontAwesome seems to be used for the little double-arrow icons on the widget sidebar menu:

    #page .widget.widget_recent_entries ul li::before, #page .widget.widget_archive ul li::before, #page .widget.widget_nav_menu ul li::before, #page .widget.widget_pages ul li::before, #page .widget.widget_meta ul li::before, #page .widget.widget_categories ul li::before, body.pen_has_woocommerce #page .widget.widget_product_categories ul li::before {

    content: “\f101”;
    font-family: ‘FontAwesome’;
    font-weight: normal;
    margin: 0 1em 0 0;
    opacity: 0.75;

    }

    That’s in /pen/assets/css/pen-widgets.css, line 517. Or so my inspector says, I didn’t actually look in the file.

    Theme Author htmlpie

    (@htmlpie)

    Hi there,

    It does have the FontAwesome but it’s bundled, that plugin is loading it through the CDN.

    Thanks anyway.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘External Font Issue’ is closed to new replies.