Support » Fixing WordPress » External blog editor cannot access blog

  • I have a WordPress 2.0.2 installation on my site ( I’ve been trying to configure both Flock and Performancing to act as an external blog editor.

    Both recognize the blog and prompt for username/password and attempt to log in. But both editors kick back an error which states “Login error. Please check your username and password for errors and try again.”

    Yet the same username and password allow me access to the blog when logging directly into the WordPress installation. This and the fact that I have had no problems accessing my old account through both of these apps, leads me to believe that the problem is with the installation and/or configuration of my blog.

    So I am at a loss and I’m not sure where to start looking. Any gurus out there have any flashes of brilliance for me?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Sound to me like you might NOT be using the user name and password from your config.php? But instead are using your WP login details.

    That’s all I can think of. Hope it helps..

    Isn’t the username in the wp-config file simply used to access the mySQL db?

    Although I did try it to see if it had any effect – I received the same rejection letter.

    I am wondering if it is a permissions issue with the files in that they won’t allow external access but I am not sure which file would control login access. Hmmmm…

    Sorry. I gave you bad information.

    I point Performancing to the xmlrpc.php file

    eg http://whatever/wordpress/xmlrpc.php

    and I use the same login details I use to access the dashboard.

    That’s what I tried as well. It sees the blog, brings up the login screen and then promptly fails to authenticate. I even went so far as to reinstall the app. The .htaccess is the standard mod_rewrite with no additional tweaks.

    I’m out of ideas at this point.

    I’ve since uninstalled Performancing as I can’t see that much difference in using it vs the WP editor.

    I mostly use ECTO — I think you can get a demo.

    Damn, you’re using the newest version? There were problems with earlier versions. Also, sometimes the server itself imposes filesize upload limits that can conflict.

    Ok, so I am still having problems.

    Checked with my host and they had me add my IP range to the mySQL authorized IP list. Done. Still no luck.

    It seems to keep kicking back the authentication credentials as I am prompted for username/password and I use the same creds that allow me access directly to my blog.

    The host mentioned something about class-IXR.php but I have no idea how/why that would affect remote accessibility.


    Hi Guys.
    According to a post by a member at Performancing
    a way to fix this is as following;

    1) Under the Account settings, where the API URL is found
    (see image:
    Check the ‘Advanced Settings’ check box.

    2) Then Check the ‘Use boolean for Publishing” option.

    Please post your results here:
    or directly to me

    As I would love to get this issue resolved for the next version of Performancing. This seems to only happen to some wp users on certain hosts, so the more information the better.

    Thanks, and sorry you are having issues.


Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘External blog editor cannot access blog’ is closed to new replies.