Support » Plugin: WooCommerce » External/Affiliate Links adding extra character “?” to the URL

  • Hello,

    The affiliate link is
    https://domain.com/#a_aid=sid
    However the button link leads to
    https://domain.com/?#a_aid=sid

    Tried to trouble shoot for 5 hours yesterday. It doesn’t seem to be an issue with our theme (Divi) or any of the plugins, tried disabling those.
    Found similar issues of illegal chracters in external/affiliate links but no resolution found yet.

    Anyone?

    Thank you!

    WooCommerce version: 4.3.2
    WordPress version: 5.5
    PHP version: 7.3.16
    MySQL version: 5.6.40-84.0-log

    The page I need help with: [log in to see the link]

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Support Rynald0s.a11n

    (@rynald0s)

    Automattic Happiness Engineer

    Hi @psysid!

    Does the ? actually cause any issues with the redirect or anything?

    That only acts as separator, it indicates end of URL resource path and start of query parameters, which seems normal to me.

    Cheers!

    Thread Starter thespecializt

    (@psysid)

    Hi @rynald0s

    Thanks for your support.

    Well the tracking of affiliate links fails, ideally there should not be any changes in the links. This issue only happens on its own with the add to cart or buy now button. If a text link is created it doesn’t happen.

    Also some affiliate programs have a “?” character in them too, I wonder how this would affect such links, thankfully my affiliate links don’t have that but a “#”.. but still seems like a bug in woocommerce external/affiliate links.

    Will be greatful if a resolution happens.

    Thanks!
    Sid

    Plugin Support Ena P (a11n)

    (@drwpcom)

    Hi @psysid. How are you creating these affiliate links? Using a link like /#ref is usually used for anchor links.

    Thread Starter thespecializt

    (@psysid)

    Affiliate links are given to us by the owners of the company, so not possible to change them.’

    Any reason why Woo suddenly decided to mess with these links?

    Somehow the tracking is still working, but its quite bad that links are getting changed automatically

    Plugin Support Ena P (a11n)

    (@drwpcom)

    Hi @psysid. The ? is being added by the browser. The button is a submit on a form vs being a link. The form handling in the browser automatically adds the ? because a form is expected to have data fields that would be sent.

    Thread Starter thespecializt

    (@psysid)

    Thanks for your response.

    I’m not sure why this is happening only now. Anything you can suggest to avoid this issue? I think Woo should update the plugin so this doesn’t occur, maybe swap the code for affiliate links somehow

    Plugin Support Ena P (a11n)

    (@drwpcom)

    Hi @psysid. I’m afraid that I’m unfamiliar with any workarounds to use in this case. If you’d like to report this to the developers, you can post the issue to Github.

    Thread Starter thespecializt

    (@psysid)

    Thanks I’ve raised the issue on github. Although I must say that being a wordpress plugin available on wordpress.org I would expect the plugin developers to respond and provide support/resolution on this forum.

    Plugin Support Ena P (a11n)

    (@drwpcom)

    Hi @psysid. We provide help with the plugin in the forum for the existing functionality of WooCommerce. For issues such as bug reports, this is done through Github.

    I noticed this today too when setting up a new site for a client that uses all external links. I know the last time I set this a couple years ago, the behavior wasn’t like that. Whatever link you set in the affiliate/external link is where the purchase button took you to… now it adds a ? to the end of the URL.

    Thread Starter thespecializt

    (@psysid)

    This existing functionality of woocommerce is broken – affiliate links are not correctly translated πŸ™‚
    Wordpress.org plugin support system is also broken if this issue can’t be fixed here πŸ™‚

    Thread Starter thespecializt

    (@psysid)

    u do realize that people are undoubtfully and unknowningly loosing money due to this?

    Plugin Support Rynald0s.a11n

    (@rynald0s)

    Automattic Happiness Engineer

    Hi @psysid!

    I had another look into this and you are correct in saying that a couple of versions back this wasn’t the case. I was able to replicate it for the most recent version, but not for v4.2.0 (as an example).

    With that said, I found your Github issue here https://github.com/woocommerce/woocommerce/issues/27727 and will chime in there.

    Please do follow along.

    Cheers!

    Thread Starter thespecializt

    (@psysid)

    Hi Rynald0s,

    Thanks for testing it again, I hope the development team fixes it in the next version.

    Many affiliate platforms might invalidate the links with an extra character, some of them use anchor links to track the referral, so I think this could be a problem for those using Woo to promote affiliate products.

    In our case, our shop is hybrid, affiliate and own products, so woocommerce affiliate/referral urls really add to the user experience of being able to compare products and make good buying decisions.. I really wish this can be fixed πŸ™‚

    cheers

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘External/Affiliate Links adding extra character “?” to the URL’ is closed to new replies.