WordPress.org

Support

Support » Plugins and Hacks » Social Hashtags » [Resolved] Extent to other APIs

[Resolved] Extent to other APIs

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author shanaver

    @shanaver

    Jeff,

    For sure – just go into the lib/platforms.class.php file and copy one of the existing ones and tweak it for the new service.

    Per twitter, that one is already in there, but I built it before the v1.1 API Oauth changes so it needs to be fixed to work with that now. You could just do some fixes on that and it would probably be good to go in a few hours.

    If you get it working, I’d love to add it in for other people to use – if you’re down with that.

    Thanks!
    Bryan

    Plugin Author shanaver

    @shanaver

    I’m assuming this is resolved

    i would like to see the twitter code if possible. I’m trying to do the same thing. Not as savvy as you guys on modifying code.

    Plugin Author shanaver

    @shanaver

    The old twitter code (based on the Twitter 1.0 API) is still in the platforms.class.php file.

    The new Twitter 1.1 API Docs are here:
    https://dev.twitter.com/docs/api/1.1

    Essentially, if you want to hook into twitter you’ll need to tweak the platforms.class.php file to use the new API – which is probably a days worth of work. If you want to tackle it, and don’t mind providing the new code, I’ll add it to the plugin. I don’t currently have the time to do it myself, unfortunately.

    Has anyone successfully modified the Twitter code to support the new API? The plug-in does exactly what I need, but Twitter support’s necessary on my project and the code modifications the new API requires go way over my head.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Extent to other APIs’ is closed to new replies.
Skip to toolbar