Support » Plugin: Meta Box - WordPress Custom Fields Framework » Extensions JS & CSS not loading in

  • I’m not positive this is the issue but here’s what it seems like:

    I have a user profile form on a page locked behind a login requirement. This profile form uses a large set of custom fields with various tabs and conditional logic being applied.

    I can’t seem to pin down the update that broke this, but for some reason it appears that the CSS and JS for the extensions (notably Tabs and Conditional Logic, but also image upload fields) aren’t loading in on the page. I’ve tried rolling back the plugin to several earlier versions as well as deactivated every plugin on my site and switched to the default theme. None seem to provide a working solution.

    Doesn’t help that I can’t tell which files aren’t loading in that are supposed to be.

    I can send page link and login in a private reply.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Whenever you change something, do you flush any caches and force your browser to reload the page without caching?

    Also, if you’re using PHP Opcode Caching, you might need to invalidate your cache, because PHP may not be aware of plugin deactivations, which are done in the database.

    Hi Gal, thanks for the response.

    Yes I’ve been flushing caches almost consistently as I work. I’m not familiar with Opcode caching, is that something specific to Apache?

    We are running an Nginx server with WordPress 5.3

    Tried using Twentynineteen theme, and no other plugins activated except for: Metabox v5.2.4, and Metabox AIO v1.10.11

    Activated extensions are:
    – MB Frontend Submissions
    – MB Relationships
    – MB User Meta
    – MB User Profile
    – MB Builder
    – MB Columns
    – MB Conditional Logic
    – MB FacetWP Integrator
    – Geolocation
    – Group
    – Include Exclude
    – Tabs
    – Tooltip

    I suppose the problem might not be CSS/JS related but as some of the styles aren’t working (Tabs, for example, just show as an unordered list above the form), and the conditional logic isn’t being applied, I have no idea what else could be going wrong.

    I have a sneaky suspcion that either the plugin is not fully installed, or WordPress isn’t.

    Try deactivating the plugin, removing it using FTP (i.e. without deleting its data), and then reinstalling it from WordPress (Plugins > Add New > Upload).

    On the Updates page, you can also reinstall WordPress core, if this doesn’t fix it.

    Thanks for the suggestion Gal – I went in and removed the plugin as you suggested as well as re-installed the WP Core but unfortunately I’m still having the issue.

    Will try installing the plugins on a fresh local install and see if I can replicate the issue.

    note: i didn’t re-install the AIO/extensions plugin. I will see about re-downloading that and re-installing as well.

    • This reply was modified 1 month, 2 weeks ago by corybolles.

    I suppose now you need to test deactivating some of the extensions and even the whole AIO plugin.

    However, since you’re using premium extensions, you’re more likely to get resolution by opening a ticket and letting the MB team check your site directly.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.