WordPress.org

Support

Support » Plugins and Hacks » Hacks » Extending wp_editor to include HTML5 data- attributes

Extending wp_editor to include HTML5 data- attributes

  • Aaron Dicks

    @aarondicks

    I’m trying to use jqBootstrapValidation on my theme. It relies on being able to detect HTML5 validation elements on form elements, along with it’s own recognisable data API.
    I need to have the wp_editor screen recognised as ‘required‘ and add a minlength attribute too; minlength="10"
    Is there a way to programatically add this to thw wp_editor, or are there any other custom filters that I can be using to make this a little easier for myself?
    Failing this, I think I’ll need to write some custom JS on the AJAX POST…

    Any help would really be appreciated!

    For those unfamiliar with the plugin, it’s here

  • The topic ‘Extending wp_editor to include HTML5 data- attributes’ is closed to new replies.