Support » Plugin: WooCommerce Square » Exposed code in zipcode potion of checkout field

  • Resolved ckruger


    The checkout field on the site displays underneath the zipcode area:

    #sq-nudata-modal { z-index: 999999 !important; }

    Not sure whats happening here

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support Hannah S.


    Automattic Happiness Engineer

    Hey there!

    I see what you mean – the code is showing up on the checkout block:

    CSS on checkout
    Link to image:

    Looking at the page’s code, there’s no clear indication of what’s making that CSS show up on your page.

    It looks like it might have something to do with security, based on this:

    However, we haven’t had any other reports of this problem and I can’t reproduce it on my end. That leads me to think that there’s something on your site that’s forcing that code to show up.

    This kind of problem is usually caused by either a conflict with your theme or with another plugin.
    The best way to determine this is to:

    • Temporarily switch your theme to Storefront
    • Disable all plugins except for WooCommerce
    • Repeat the action that is causing the problem

    If you’re not seeing the same problem after completing the conflict test, then you know the problem was with the plugins and/or theme you deactivated. To figure out which plugin is causing the problem, reactivate your other plugins one by one, testing after each, until you find the one causing conflict. You can find a more detailed explanation on how to do a conflict test here.

    Please do let me know how that goes!



    Thanks for the reply. I tried another theme and the problem went away so it seems to be a theme problem. Is there anyway I can just hide that from displaying?

    Plugin Support Hannah S.


    Automattic Happiness Engineer

    Hey there,

    I’m glad you were able to narrow it down to your theme.

    I took a look at the code to see if it’s something that can just be hidden. There isn’t anything to address to hide it, short of possibly writing custom JavaScript to target that specific line:

    Link to image:

    The best thing to do here is to reach out to your theme’s developer and ask them to take a look.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.