[resolved] Exporting a large number of tables (4 posts)

  1. mvhoute
    Posted 3 years ago #


    I've added quite a lot of tables (63) into a development enviroment. Now I want to move the content to the live enviroment, so I wanted to export all tables.

    I've selected all tables, clicked on Export table, and then I got this screen in front of me:

    I've tried different settings (csv / HTML / JSON), even with only one item, but the error keeps repeating.

    The page /wp-admin/admin-post.php DOES exist in my WordPress install..

    Are there other ways to export the files, or is there a way to fix the problem?


  2. TobiasBg
    Plugin Author

    Posted 3 years ago #


    thanks for your question, and sorry for the trouble.

    From what I can see, this is not an issue about /wp-admin/admin-post.php not existing, but more about the encoding of the data that is being sent. (That's indicated by the "Error 330" that you can see at the bottom of your screenshot.)
    I found this thread, which has some ideas on what might be going on: http://superuser.com/questions/172951/chrome-error-330-neterr-content-decoding-failed

    So, what you could try:
    - Use a different browser for the export.
    If that also does not help:
    - Temporarily disable all other plugins and switch to the WordPress Default theme.
    If that doesn't help, there's probably some incompatibility between the TablePress HTTP headers that are sent for the download, the server, and the browser.

    If these two suggestions also do not work, we can still use the export that WordPress offers for "Custom Post Types". That will be slightly more work, but don't worry, we'll get your data moved to the live environment :-)


  3. mvhoute
    Posted 3 years ago #

    So, another browser AND disabling all the plugins (except Tablepress) did the trick. Thanks!

  4. TobiasBg
    Plugin Author

    Posted 3 years ago #


    thanks for checking this! Good to see that you at least were able to export the tables now!

    The necessity of deactivating all other plugins indicates, that there was some kind of incompatibility. However, it's still kind of strange that this requires a different browser than Chrome... Have you tried this again after clearing Chrome's cache?
    Also, after moving your tables to the live site, can you try the export from there again? Would be good to know if the same problem occurs there as well, or if it was only on your dev site.


Topic Closed

This topic has been closed to new replies.

About this Plugin

  • TablePress
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic