WordPress.org

Support

Support » How-To and Troubleshooting » Export not including posts in XML file

Export not including posts in XML file

  • I am running WP3 multisite and am trying to export from one of my blogs from a category called “Featured”. It has 3 posts in it, however, when I select “Featured” from the “Categories” select box and click “Download Export File”, the generated xml file only has categories and tags in it, no posts.

    Is this a bug or am I just doing something wrong? Doesn’t seem like I am though…all other select boxes are set to their default “All” settings. And if it matters, I upgraded from WPMU 2.9.2 to WP3.0.

    Thanks!

Viewing 1 replies (of 1 total)
  • hi,
    i got the same problem here.

    Anyway i am looking for a script-based solution to export _all_ WPMU-Objects (i mean everything ;)) from a WPMU 2.7 to a brandnew 3.0.1 Multisite.

    I found some plugins (Advanced Export for WP & WPMU, WP Cloner, a PERL script.. whatever), but none of them suits my needs.
    My main problem are some misconfigurations in the user-roles of the source install, so i would like to fix them inside the XML, trying to get some clean db entries.

    I need (as i think atm, correct me..) a script which is exporting/importing all blogs, users and their specifications with the possibility to change some fields within the XML-file.

    I already began with a clone of wp-admin/includes/export.php, which i copied to mu-plugins to have the funcs available in a easy way.

    Yes, i also have changed the function names, and the clone is running without errors. The only thing is: I don’t have any post or comments inside the XML, only categories and some meta infos.

    any help would be appreciated
    thx!

Viewing 1 replies (of 1 total)
  • The topic ‘Export not including posts in XML file’ is closed to new replies.
Skip to toolbar