Support » Plugin: Page Builder by SiteOrigin » ‘Export Layout’ problem with Wordfence 7.4.5 (year 2020)

  • Resolved Joan Morci


    Hi guys!

    I am sorry to return with this problem but something has changed in Wordfence 7.4.5 and it does not work the same, with the same steps we followed in a previous post, 2 years ago.

    I had to deactivate Wordfence for a few seconds to be able to export (Download the structure).

    This happens to me in structures of many rows. See here.

    I hope solution, if this is possible.


    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Andrew Misplon


    Hi Joan

    Thanks for reaching out.

    If you set the Wordfence firewall to learning mode the export should be allowed. You can then disable learning mode.

    Let us know how that goes.

    Thread Starter Joan Morci


    Hi Andrew @misplon!

    Thank you very much for your answer. In effect, that is the solution to the problem.

    I read about this action on the Wordfence help page:
    – Firewall Learning Mode:

    The route is in:
    Wordfence> Firewall> All Firewall Options> Web Application Firewall Status:
    .- Enabled and Protecting (default is this one)
    .- Learning Mode (this option is what interests us for a few seconds to activate, then return to ‘Enabled and Protecting’)
    .- Disabled

    I have read (and checked) that while ‘Learning Mode’ is active the actions we do go to the whitelist and remain there until we decide to remove them.

    The only thing that Wordfence advise against using ‘Learning Mode’ if the website was hacked or is currently under threat attack.

    In summary when this option, ‘Learning Mode’, remains active these actions occur:
    – Some applications that seem suspicious are included in the white list.
    – Other parts of the firewall remain fully active:
    .- Including Brute Force Protection
    .- Login Security
    .- The blocking functions

    Although it is a better option than deactivating the plugin, there is a risk of being infected in that period of time, so it will be necessary to act quickly once we use the Page Builder by SiteOrigin.

    Greetings and thanks again 🙂

    • This reply was modified 1 year, 2 months ago by Joan Morci. Reason: @misplon without parentheses
    • This reply was modified 1 year, 2 months ago by Joan Morci. Reason: removing link to Wordfence to avoid management / approval comment
    Plugin Author Andrew Misplon


    Hi Joan

    It should only be necessary to activate Learning Mode once. Activate Learning Mode, go to a page, download a Page Builder export then deactivate Learning Mode. Page Builder exports should then work as expected.

    Plugin Author Andrew Misplon


    Hi, thanks for replies 🙂 I am receiving them via email. Sorry, I should have mentioned that.

    Learning Mode should only need to be activated for a minute or perhaps two. This will only be required for the first time an export is made. So yes, I’m with you when you highlight the risk of Learning Mode but it only needs to be done once and very briefly.

    Moderator Steven Stern (sterndata)


    Forum Moderator & Support Team Volunteer

    >> I do not know if you have seen my message (written 1h before) because the WordPress team has retained it, <<

    The system flagged your original message (and the follow ups) as spam. I’ve unflagged the original and archived the other two.

    Plugin Author Andrew Misplon


    Thanks for the help, Steve 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘‘Export Layout’ problem with Wordfence 7.4.5 (year 2020)’ is closed to new replies.