Support » Plugin: Timetable and Event Schedule by MotoPress » Export/Import errors

  • Resolved ulicgn

    (@ulicgn)


    Hi,

    this might possibly related to https://wordpress.org/support/topic/import-issue-12/, but I am not sure, so I open a new issue with additional observations

    For preparing events and schedules I am using a clone of a public site. In the clone, I set up the Columns, Events and Timeslots. Both sites are completely up-to-date regarding WordPress Core, Plugins and PHP versions.

    When exporting from wp-admin/edit.php?post_type=mp-event&page=mptt-import, no visible error message is shown and an export file is generated.
    When importing this file on the target site, first the mapping of authors is shown, and then the successful import is confirmed and there is no visible error message . However, only the Categories got imported completely, there was only one column imported, and no event and no timeslot whatsoever.

    My observations:
    1) The export generates an invalid XML file. After the closing rss tag, additional wordpress error output is included – see below
    2) When trying to import the invalid XML file, there is NO indication for the user that something is wrong ( like I described above – no error message, import is confirmed)
    3) When enabling DEBUG mode in the target before importing, no errors are to be found in the debug.log, only some notices show up at the time of the import:

    [01-Feb-2021 10:56:33 UTC] PHP Notice:  Trying to access array offset on value of type int in /hp/bw/aa/ei/www/ballett-bewegung/christianedemo/wp-includes/formatting.php on line 884
    (repeated 8 times)
    [01-Feb-2021 10:56:33 UTC] PHP Notice:  Trying to access array offset on value of type int in /hp/bw/aa/ei/www/ballett-bewegung/christianedemo/wp-includes/formatting.php on line 884

    3) After fixing the XML file by simply deleting everything after the closing rss (and validating the xml), the import works fine. Looking at the content of the XML file it looks as if it contains all components (events, columns,categories,timeslots)

    Summing up:
    * the export generates invalid XML without showing an error
    * the import chokes on invalid XML also without showing errors
    * importing a manually fixed XML file works fine

    Regards
    Ulrich

    THis is how the invalid export file looks:

    <?xml version="1.0" encoding="UTF-8" ?>
    		<!-- generator="WordPress/5.6" created="2021-02-01 11:15" -->
    
    		<rss version="2.0"
    		     xmlns:excerpt="http://wordpress.org/export/1.2/excerpt/"
    		     xmlns:content="http://purl.org/rss/1.0/modules/content/"
    		     xmlns:wfw="http://wellformedweb.org/CommentAPI/"
    		     xmlns:dc="http://purl.org/dc/elements/1.1/"
    		     xmlns:wp="http://wordpress.org/export/1.2/">
    			<channel>
    				[content omitted - the content contains all necessary items and seems ok]
    								</channel>
    		</rss>
    		<!DOCTYPE html>
    <html lang="de-DE">
    <head>
    	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    	<meta name="viewport" content="width=device-width">
    		<meta name='robots' content='noindex,nofollow' />
    	<title>WordPress &rsaquo; Fehler</title>
    	<style type="text/css">
    		html {
    			background: #f1f1f1;
    		}
    		body {
    			background: #fff;
    			color: #444;
    			font-family: -apple-system, BlinkMacSystemFont, "Segoe UI", Roboto, Oxygen-Sans, Ubuntu, Cantarell, "Helvetica Neue", sans-serif;
    			margin: 2em auto;
    			padding: 1em 2em;
    			max-width: 700px;
    			-webkit-box-shadow: 0 1px 3px rgba(0, 0, 0, 0.13);
    			box-shadow: 0 1px 3px rgba(0, 0, 0, 0.13);
    		}
    		h1 {
    			border-bottom: 1px solid #dadada;
    			clear: both;
    			color: #666;
    			font-size: 24px;
    			margin: 30px 0 0 0;
    			padding: 0;
    			padding-bottom: 7px;
    		}
    		#error-page {
    			margin-top: 50px;
    		}
    		#error-page p,
    		#error-page .wp-die-message {
    			font-size: 14px;
    			line-height: 1.5;
    			margin: 25px 0 20px;
    		}
    		#error-page code {
    			font-family: Consolas, Monaco, monospace;
    		}
    		ul li {
    			margin-bottom: 10px;
    			font-size: 14px ;
    		}
    		a {
    			color: #0073aa;
    		}
    		a:hover,
    		a:active {
    			color: #006799;
    		}
    		a:focus {
    			color: #124964;
    			-webkit-box-shadow:
    				0 0 0 1px #5b9dd9,
    				0 0 2px 1px rgba(30, 140, 190, 0.8);
    			box-shadow:
    				0 0 0 1px #5b9dd9,
    				0 0 2px 1px rgba(30, 140, 190, 0.8);
    			outline: none;
    		}
    		.button {
    			background: #f7f7f7;
    			border: 1px solid #ccc;
    			color: #555;
    			display: inline-block;
    			text-decoration: none;
    			font-size: 13px;
    			line-height: 2;
    			height: 28px;
    			margin: 0;
    			padding: 0 10px 1px;
    			cursor: pointer;
    			-webkit-border-radius: 3px;
    			-webkit-appearance: none;
    			border-radius: 3px;
    			white-space: nowrap;
    			-webkit-box-sizing: border-box;
    			-moz-box-sizing:    border-box;
    			box-sizing:         border-box;
    
    			-webkit-box-shadow: 0 1px 0 #ccc;
    			box-shadow: 0 1px 0 #ccc;
    			vertical-align: top;
    		}
    
    		.button.button-large {
    			height: 30px;
    			line-height: 2.15384615;
    			padding: 0 12px 2px;
    		}
    
    		.button:hover,
    		.button:focus {
    			background: #fafafa;
    			border-color: #999;
    			color: #23282d;
    		}
    
    		.button:focus {
    			border-color: #5b9dd9;
    			-webkit-box-shadow: 0 0 3px rgba(0, 115, 170, 0.8);
    			box-shadow: 0 0 3px rgba(0, 115, 170, 0.8);
    			outline: none;
    		}
    
    		.button:active {
    			background: #eee;
    			border-color: #999;
    			-webkit-box-shadow: inset 0 2px 5px -3px rgba(0, 0, 0, 0.5);
    			box-shadow: inset 0 2px 5px -3px rgba(0, 0, 0, 0.5);
    		}
    
    			</style>
    </head>
    <body id="error-page">
    	<div class="wp-die-message"></div></body>
    </html>

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Thread Starter ulicgn

    (@ulicgn)

    I append my active plugins.
    PHP is 7.4.11

    However: I created a fresh clone , with NO PLUGINS other than mp-timetables active, and with twentytwentyone theme activated. Still same effect – invalid xml generated, containing errors.

    -- WordPress Active Plugins
    
    Advanced WordPress Backgrounds: 1.7.1
    Contact Form 7: 5.3.2
    Flamingo: 2.2.1
    Gutenberg Blocks and Template Library by Otter: 1.6.0
    Neve Hooks: 1.0.1
    Out of the Block: OpenStreetMap: 1.3
    Pixabay Images: 3.4
    Statify: 1.8.1
    TablePress: 1.12
    Timetable and Event Schedule: 2.3.12
    uli_microdata: 0.5
    WordPress Importer: 0.7
    WP Dashboard Notes: 1.0.10
    WP STAGING: 2.8.0
    

    PHP is 7.4.11

    Regards
    Ulrich

    Plugin Support Dmytro

    (@dimned)

    Hi Ulrich @ulicgn,
    Thanks for reporting this. We’ll take a closer look at it and notify you if we have any news.

    Plugin Author MotoPress

    (@motopress)

    @ulicgn This issue is fixed in version 2.3.15.

    Thread Starter ulicgn

    (@ulicgn)

    I can confirm that it works. I have exported my Timetable content ( 7 columns, several Events and Categories) and checked the XML. It looks ok, and also it validates. Then I was able to import it sucessfully into an empty test clone installation.

    @motopress @dimned Thank you for fixing!

    Plugin Support Dmytro

    (@dimned)

    Hi @ulicgn,
    Thank you for your collaboration and feedback.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.