Support » Plugin: Autoptimize » expiry not working

  • Resolved Allon Sacks

    (@allonsacksgmailcom)


    Hi,

    I set in wpsupercache expiry to 172800 seconds and in my main htaccess file like on all my sites it is also set to a high number:
    A31536000
    I see in the cache/autoptimize folder the htaccess file it is set to:
    A30672000

    But in google page speed it is telling me that the autoptimized files are set to expire in 3 seconds. Other js files that I skip optimizing do not get this message so I know that setting expiry on the server is working.

    I tried unchecking “Save aggregated script/css as static files?” but all it did is server those files with a php extension and still got the warning.

    Any ideas?

    Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    that means *something* is overwriting AO’s expiry headers with alternate .htacces rules @allonsacksgmailcom, you’ll have to toggle other plugins (hoping they clean up any changes they make to .htaccess files when deactivated) to see which one.

    hope this helps,
    frank

    Allon Sacks

    (@allonsacksgmailcom)

    Wow thanks for the quick response! And that pointed me in the right direction and I fixed it.
    Actually I found in the wp-content/cache folder an htaccess file with the following. I wonder where it came from as after deleting and resaving wpsupercache it did not return this bothersome code:

    # BEGIN supercache
    <IfModule mod_mime.c>
    <FilesMatch “\.html\.gz$”>
    ForceType text/html
    FileETag None
    </FilesMatch>
    AddEncoding gzip .gz
    AddType text/html .gz
    </IfModule>
    <IfModule mod_deflate.c>
    SetEnvIfNoCase Request_URI \.gz$ no-gzip
    </IfModule>
    <IfModule mod_headers.c>
    Header set Vary “Accept-Encoding, Cookie”
    Header set Cache-Control ‘max-age=3, must-revalidate’
    </IfModule>
    <IfModule mod_expires.c>
    ExpiresActive On
    ExpiresByType text/html A3
    </IfModule>
    Options -Indexes

    # END supercache

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    I *think* this is the (old?) .htaccess for the rewrite-based mode of wp super cache (as opposed to legacy and php-based modes). but great you found it!

    enjoy the rest of your sunday! 🙂
    frank

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘expiry not working’ is closed to new replies.