Support » Plugin: LiteSpeed Cache » ExpiresDefault error message – remove from .htaccess file?

  • Resolved HMSRE

    (@hmsre)


    Just updated to Version 1.1.4 today and getting an error:

    ERROR 4010: In .htaccess file found one unexpected cache rule ExpiresDefault l

    This is what I currently have in my .htaccess file (which I thought is helpful to speed test results and performance).

    ## EXPIRES CACHING ##
    <IfModule mod_expires.c>
    ExpiresActive On
    ExpiresByType image/jpg “access plus 1 year”
    ExpiresByType image/jpeg “access plus 1 year”
    ExpiresByType image/gif “access plus 1 year”
    ExpiresByType image/png “access plus 1 year”
    ExpiresByType text/css “access plus 1 month”
    ExpiresByType application/pdf “access plus 1 month”
    ExpiresByType text/x-javascript “access plus 1 month”
    ExpiresByType application/x-shockwave-flash “access plus 1 month”
    ExpiresByType image/x-icon “access plus 1 year”
    ExpiresDefault “access plus 2 days”
    </IfModule>
    ## EXPIRES CACHING ##

    What’s the reason in removing this from my .htaccess file? Does Litespeed handle this in the plugin vs .htaccess? Thx.

    Dave

Viewing 15 replies - 1 through 15 (of 20 total)
  • Plugin Author Hai@LiteSpeed⚡

    (@hailite)

    Hi Dave,

    You may need to remove or comment the line ExpiresDefault “access plus 2 days”.

    This will send another cache control header and your browser will cache it. So if a page is purged and user will still see the previous browser cached version, until they did a refresh. Especially for woocommerce sites, this is not good.

    Best regards,
    Hai

    Plugin Author Hai@LiteSpeed⚡

    (@hailite)

    However, if you insist to keep it in .htaccess, please add a space before it, then the error message will disappear.

    I think I follow – I will remove that line… I just know all the speed test sites state to leverage browser caching and most tutorials have the same line to include.

    Love the plugin so far – it was so needed and much better that w3tc so far.

    Plugin Author Hai@LiteSpeed⚡

    (@hailite)

    Or, if you want to keep the default one, try to add this one before it:

    ExpiresByType text/html "access plus 0 seconds"

    Plugin Author Hai@LiteSpeed⚡

    (@hailite)

    Glad you like it.

    If you have any future question, please don’t hesitate to let us know.

    A positive review will be a great support to us: https://wordpress.org/support/plugin/litespeed-cache/reviews/?filter=5#new-post

    Thanks.

    Plugin Author LiteSpeed Technologies

    (@litespeedtech)

    Hi Dave,

    If you’d like to keep ExpiresDefault for other unlisted file types that you may want to be cached by the browser, you can also try adding the following instead:

    ExpiresByType text/html "access plus 0 seconds"

    This should override the ExpiresDefault setting and allow LiteSpeed Cache to handle caching the page, instead of the browser. For the time being, also include the “space” as mentioned earlier to remove the error message.

    Regards,
    -Michael

    Hi,
    I have deleted the line in .htaccess
    ExpiresDefault “access plus 2 days”

    but the error still remains.

    Could you please show me how to clear this error.

    Thanks so much,
    Vu Tran

    Plugin Author Hai@LiteSpeed⚡

    (@hailite)

    Hi @thevu,

    As long as your rewrite file doesn’t have any ExpiresDefault in it, once you refresh the wp-admin again, it should disappear.

    Are you modify the correct htaccess file?

    Hi,

    That means I have to delete all sentences have the “ExpiresDefault” manually in the .htaccess file?
    Yes, I have modified a little bit htacess file.
    Could you please tell me how can I take the original htaccess file?

    Thanks,
    Vu Tran

    I chose to add the space in front of the “ExpiresDefault” line and it seems to work great. Save htaccess file and hard-refresh your admin page. It goes away.

    Thanks Team LS.

    Dave Geipel

    Plugin Author Hai@LiteSpeed⚡

    (@hailite)

    Can you please paste the current .htaccess content and path?

    Yes you need to remove them or add some space before them to bypass the check. If you bypass it, do add text/html header to no cache to avoid browser cache for php

    Hi,

    I have restored the htaccess file (using R1Soft backup module).
    Then I just deleted one line with “ExpiresDefault”.
    Refresh my site (by purging cache)
    Now it has no error at all.
    Thank for your kindly support!

    Plugin Support LiteSpeed Lisa

    (@lclarke)

    Hi, guys, glad to hear the message has gone away!

    For anyone else having this issue, we’ve got a new wiki entry that might help.

    And, of course, we are happy to answer your questions here, if that link doesn’t help.

    Happy Caching!
    Lisa@LiteSpeed

    Plugin Author Hai@LiteSpeed⚡

    (@hailite)

    Hi @thevu,

    You are most welcome. Enjoy the high speed~

    We are glad to see any feedback or positive review, here is the link: https://wordpress.org/support/plugin/litespeed-cache/reviews/?filter=5#new-post

    Cheers,
    Hai

    Done – 5 Stars!

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘ExpiresDefault error message – remove from .htaccess file?’ is closed to new replies.