Support » Plugin: WP REST Cache » Expired records for pages in child sites

  • Resolved beltranrengifo

    (@beltranrengifo)


    Hi there!
    First of allm thankxs for sharing this plugins, it’s working fine in most cases, but I have a doubt I want to share with you..

    We use a custom endpoint to retrieve pages, ie:
    /HOME
    /utilities/
    OR
    /products/customers
    This product (Customers) is a child site. We sent the site_name param in the request, so we can change WP context in the route handler function, set the child site context, retrieve content, and send it to the front-end.

    Well, in this case, I see the record is expired always. All pages loaded from this “child contexts” are marked as expired. I don’t understand, as they are using the same endpoint… Maybe is related to something internal is doing the plugin or the CMS?

    https://imgur.com/BV2LVNe

    Let me know if you can point me in the right direction.
    Thanks again!

    • This topic was modified 3 months, 3 weeks ago by Jan Dembowski.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Richard Korthuis

    (@rockfire)

    Hi @beltranrengifo

    Thank you for using our plugin!

    In your screenshot I see only one expired cache and it is marked “Expired”. Expired means it has an expiration date with a timestamp > 0. If it would have had an expiration date with timestamp = 0, it would have been marked as “Flushed”. So somehow this cache record is getting a wrong expiration date OR the cache record has indeed expired. Could you delete the cache record and then have it regenerated by calling the endpoint? Next check what expiration date is in the database table wp_wrc_caches in the column expiration. I’m interested in that date/time and the date/time you did the actual request. Please also check the cache settings for the setting of the Cache timeout.

    Plugin Author Richard Korthuis

    (@rockfire)

    This thread has been marked as resolved due to lack of activity.

    You’re always welcome to open a new topic.

    Thanks for understanding!

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.