WordPress.org

Support

Support » How-To and Troubleshooting » Experiencing random “Internal server Errors” (Update WP 2.9)

Experiencing random “Internal server Errors” (Update WP 2.9)

  • Hi everyone,

    just a quick question if anyone else is experiencing the same problem.

    Update to latest WP version (2.9) went smoothly and my site seems to run without a problem.

    But …

    When I try to edit a longer post, I get completely irregular “Internal server Errors”. I’ve had 6 of these in the last two hours. Sometimes edits work fine … but take a long time to be saved to the server).

    Now I’m wondering if …

    a) it’s my host (has been stable for years without a single server error for about 8 or 9 years!)

    b) or if sth changed with WP 2.9 (f.ex. longer runtime for scripts or sth like that) that could cause this error.

    Again, I’ve never had this problem before.

    Any comment or help is appreciated.

    deus62

    P.S.: The post in question is this one (editing works 50% of the time … for the rest I get server errors):

    http://livingwithmusic.com/mosaic/

Viewing 15 replies - 1 through 15 (of 25 total)
  • What’s inside errors_log of apache?

    I do not have access to error logs. I think.

    If anyone else reads this, has script time in WP 2.9 increased (substantially)?

    I have the feeling that’s my problem. I’m on manged hosting that sets script run-time limits for the various accounts.

    Unfortunately, I don’t have access to error logs (only to FTP and access logs).

    Yep.
    Looks like the WP update pushed me above script limits.
    Bummer.
    :/

    OK, but if it sometimes works and sometimes doesn’t, file permissions can’t really be the culprits, can they?

    You shoudn’t get 500 error if you have not enough memory, usually php shows error like ‘tried to allocate … memory exhausted …’ on most mod_php web hostings. But it can be 500 error on some fast-cgi/cgi web hostings with memory limit per user account in OS. Depends on how web server is configured.

    If your web hosting is mod_php based and you got 500 error so u should contact your web hosting provider about a problem. For example, I’ve got a same problem when used a web hosting with IIS + php configured and the problem was solved with a php downgrade.

    I am having the same issue.

    Error logs state:
    [Sat Dec 19 20:54:43 2009] [error] [client xxx] Premature end of script headers: post.php, referer: http://www.mortfiles.se/xxx/wp-admin/post-new.php
    [Sat Dec 19 20:54:43 2009] [error] [client xxx] File does not exist: /home/mfse01/public_html/500.shtml, referer: http://www.mortfiles.se/xxx/wp-admin/post-new.php
    [Sat Dec 19 20:54:53 2009] [warn] mod_fcgid: process 19804 graceful kill fail, sending SIGKILL

    [Sat Dec 19 20:57:52 2009] [error] [client xxx] Premature end of script headers: post.php, referer: http://www.mortfiles.se/xxx/wp-admin/post-new.php
    [Sat Dec 19 20:57:52 2009] [error] [client xxx] File does not exist: /home/mfse01/public_html/500.shtml, referer: http://www.mortfiles.se/xxx/wp-admin/post-new.php
    [Sat Dec 19 20:57:59 2009] [warn] mod_fcgid: process 21878 graceful kill fail, sending SIGKILL

    Moderator Andrew Ozz

    @azaozz

    WordPress Dev

    You’ll probably need to contact your host’s support. Unfortunately the “Premature end of script headers” error message only means “something didn’t work…”. It can be caused by a number of things: too large error logs, a kill script that quits a process when it uses more than a certain amount of memory or CPU, routing problems, high packet loss, etc.

    To large error logs, CPU and memory I can rule out since I am the host 🙂
    Routing problem seems unlikely and package loss would effect other services as well.

    It’s only the post.php file that is causing this problem as far as i have seen. All else seem to work just fine.

    Whats confusing is that it works sometimes and sometimes not, even when dealing with the same post. If I make a preview I always have to refresh and then it shows the page. When making new posts or updating posts it seems more random.

    Horrible page load times when I’m trying to edit/publish a post or page! Often getting 505 error or Mysql server has gone away. It’s making 2.9 unusable.

    I’m also finding similar problems. Often getting 500 Internal Server Errors as well as very, very long save times.

    Looks like everything saves fine, it just doesn’t update the writer informing them and just hangs. I suggest to people struggling with slow saves simply refreshing the page and seeing if the edits, counter to what WP is saying, has been saved.

    It does post, I posted 2 posts even though the post.pm showed a Internal Server Error when posting.

    I just upgraded to the newest version of YARPP (Yet Another Related Posts Plugin) and I think it’s solved the problem for me.

    According to the YARPP twitter, there was a time-out bug that’s been fixed with the new version (3.1.2)

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘Experiencing random “Internal server Errors” (Update WP 2.9)’ is closed to new replies.
Skip to toolbar