Support » Plugins » Exhibit Install problem

  • Not seeing Exhibit area after turning plugin on. I have done the setup in the config file too.

    Has anyone else ever seen this problem? How did you solve it?

    thx Ken

Viewing 9 replies - 1 through 9 (of 9 total)
  • Exhibit only shows up if you’re editing a post, not while you create a new one. So write a new post, save it, then edit it (or hit the “Save and continue editing” button). The Exhibit frame should appear below the text entry box.

    Of course, if you’re doing that and it’s still not showing up, double-check to make sure it’s actually activated on the Plugins page and that all the included files are in the right places.

    And if it’s still playing “Violet” on you, let us know what version of PHP,Apache/IIS, and WordPress you’re using 🙂

    No such luck. I tried it again but the same thing happens. When I go to edit the entry nothing extra shows up below the Text entry. I have been trying to get RingMaster to reply for a month and nothing.

    The plugin is activated, WP v1.2.1, Exhibit 1.1d,
    PHP 4.3.x, Apache (whatever version dreamhost is using)

    I do have several other plugins activated. I can uninstall some and see if the problem fixes itself.

    Quite odd. The first time Exhibit shows up on your posting page, it should contain a link for you to click (clicking that link creates the tables in the database that Exhibit needs). Have you gotten that far with it? Or is there simply no Exhibit frame beneath the text entry box at all?

    No Exhibit frame, anywhere….I have been posting about the problem for over a month and can’t get the author to reply. I have even went to the plugin site and emailed him. I am at a loss because I see him replying to others on this list. I have followed the install to the letter.

    I know the author was complaining on his blog about supporting users that didn’t read the posts but I have read all the posts. I have tried everything on this forum to no resolve. I have used wordpress for two projects and haven’t run into anything like this before. I am pretty savy and just wanted some ideas.

    Oh Well….

    Thanks for the reply RustIndy

    I’m having the same problem — the exhibit section is not showing on my edit posts page. (Yes, I edited an existing post — it’s not there.) However, if I go to an existing page’s permalink, I get this error:

    Database error: [Table 'db.wp_exhibit' doesn't exist]
    SELECT ID FROM wp_exhibit WHERE post_ID = 2 and preview = 1 ORDER BY picorder;

    I’m using Exhibit 1.1d, WordPress 1.2.2, PHP 4.3.10, and Apache 1.3.31 under Linux.

    I’m running into this problem on a fresh WordPress install. The only modifications I’ve done is to install the AuthImage plugin; I continue to have the problem with it disabled, though.

    Aha! I solved part of the problem! My server runs PHP as a CGI module, and that’s why it wasn’t working. In exhibitimg/exhibit10i.php around line 267, you see this:

    if(preg_match('|post.php|i', $_SERVER['SCRIPT_NAME']))

    On my system, _SERVER[‘SCRIPT_NAME’] is always “/cgi-system/php.cgi”, which obviously does not match “post.php”. To make it work, I just had to change it to something that actually contained the page’s name; I used _SERVER[“PATH_INFO”] and that worked for me. I would expect that these would also work: _SERVER[“PATH_TRANSLATED”], _SERVER[“REQUEST_URI”], _SERVER[“SCRIPT_URI”], or _SERVER[“SCRIPT_URL”]. In any case, here’s what the line looks like when I replaced it:

    if(preg_match('|post.php|i', $_SERVER['PATH_INFO']))

    This made the box show up and I was able to install the database table. I’m still getting an error in the one inline frame that says Fatal error: Call to undefined function: add_action() in /path/wordpress/wp-content/plugins/exhibitimg/exhibit10i.php on line 38, though.

    Ugh, I just figured out why my other error is occurring. It’s because the scripts are using the _SERVER[“SCRIPT_NAME”] variable all over the place… which means there’s errors all over the place when PHP is run as CGI. This causes links to show up wrong, it messes up the logic in a number of places, and who knows what else.

    However, I think I found a solution to this problem (which doesn’t involve rewriting the scripts or disabling the run PHP as CGI option!). In exhibit10.php, add this line right before the line that says “/***** DON’T MODIFY BELOW HERE *****/” (around line 38):


    You might also consider adding the same line to wp-config.php to make sure other plugins that use the same coding practices will work. However, that will not work in this particular case because exhibit10.php is directly accessed as a page of its own (in the inline frame on the edit post page, for example).

    Sorry for making so many posts in this thread… but hopefully this will help someone else who is having a similar problem.

    Thanks a bunch for the quick fix. This problem has been frustrating me for a while (I use Dreamhost as well).


    When I try to post the html for a decent size table using code tags
    I keep getting a log error
    File does not exist: /home/affili43/affili43-www/wordpress/exhibit.css
    Does any oneknow where this exhibit.css
    file is?

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Exhibit Install problem’ is closed to new replies.