WordPress.org

Support

Support » Plugins and Hacks » Exhibit 1.1 Photo Gallery Plugin

Exhibit 1.1 Photo Gallery Plugin

  • Exhibit 1.1 is a huge step forward in terms of admin UI.
    1.1 adds image upload/delete, directory creation/deletion, zip-file upload extraction, individual thumbnail creation, optional user-based image directories, and no post edit page reloads. I’ve fixed a bunch of stuff, too, including some umask/chmod stuff (crosses fingers), the annoying untiled floating issue, and the images appearing under the sidebar in IE.
    Everything validates as valid XHTML, both on the published side and the admin side, and all of the features of Exhibit that you’ve come to cherish remain in there.
    I moved the installation instructions into a new readme file that should explain enough to get you going. Feel free to ask questions here, though I’ll be gone over the weekend on a trip to D.C. (Darn, no Philly WP meetup for me. 🙁 )
    Enjoy!

Viewing 15 replies - 16 through 30 (of 141 total)
  • This is great. Exhibit handles photos the way I think blog software should.
    However, are there any simple mods to have a clicked image link to a gallery program (pictorialis II for example). Would this defeat the purpose of the plugin?
    I like the control of where and how to post images, but it would be nice to be able to use exhibit as a blog-post front end to a gallery. Anyone have ideas on this, any other solutions?
    -brandon

    Ringmaster, great plugin and great features.
    One thing I would like to see is the ability to remove images just as easy as it is to add them. Since you already have code that triggers when someone clicks on an icon to add the images to the preview column, there is no reason that you can’t have this feature to remove images. You can have a little button labeled “remove” next to each thumbnail. When you click on the remove button, that image will be removed instantly from the list. This would be consistent with the behavior required to add images. maybe add in a “remove all” button as well.

    Geez… I go away for a weekend…
    @symantix:
    If you change the config directly you won’t need the special tag each time. Just change it to “preview_like_single=true”. Otherwise, I’m not exactly sure what you’re after. Keep playing with the CSS, I’m sure there are enough classes in there to get what you want.
    The rebuild thumbnails option is missing in 1.1, but not in the shortly to be released 1.1a. With extra bonus flavor! (You guys are gonna love this new thingie…)
    @dexter:
    There currently isn’t a way to break up the previews into separate lines. I’ve always thought it was a bonus that Exhibit didn’t make you count anything to have a nice layout.
    @bdrydyk:
    The reason I wrote this is because I didn’t want to install another gallery program. I was considering writing a separate page that displays just the photos in a gallery-like way. I’m not sure if I’ll actually do that, though. What sort of link did you have in mind? Most of the possibilities I can think of are outside of my scope for this project.
    @valiot:
    You’re onto me! I didn’t do exactly that in this release because I wanted to see how the javascript picker flew first. We’ll see if I can swing it. Probably not before I get a couple of other things cleaned up.

    Just a note ringmaster, I don’t have access to my config file right now but it is possible to change the image tag to include title=”IMGCAPTION” or something of that sort title=”whateverthecaptionvariableis” within the image tag to get a nice tooltip with the caption in newer versions of MSIE and Mozilla when the non-previews are moused over.

    Hi Ringmaster, I’d really like to use your Exhibit, but there comes up always the same error, when I try to upload files. I created a new directory, changed to this directory and chosed a file to upload. Upload-progres hat been shown and after this error appears:
    Warning: copy(): SAFE MODE Restriction in effect. The script whose uid is 937 is not allowed to access /home/www/web145/html/goelog/images/geismar owned by uid 33 in /home/www/web145/html/goelog/wp-content/plugins/exhibitimg/exhibit10f.php on line 654
    Warning: copy(/home/www/web145/html/goelog/images/geismar/taka0.jpg): failed to open stream: No such file or directory in /home/www/web145/html/goelog/wp-content/plugins/exhibitimg/exhibit10f.php on line 654
    Sorry. Couldn’t upload your file, “/home/www/web145/html/goelog/images/geismar/taka0.jpg”.
    Do you habe any idea, what I could do?

    You need to not run PHP in safe mode?
    This is probably out of your control. You’ll need to talk to your host about enabling file uploads for PHP in safe mode, or turning off safe mode entirely. Usually, they don’t like that.
    Basically, PHP’s safe mode is restricting your access to the directory in which PHP caches your uploaded files. Exhibit tries two methods to move these files, but your server security could be such that you just can’t do it.
    Keep in mind that you can still upload images and thumbnails via FTP and use Exhibit to load the pictures into your posts, but you won’t have any use for the k3wl upload/resample/rotate features that have been added in the last few iterations.

    Oh, by the way…
    Version 1.1a is online.

    Ringmaster, again… praise for this plug-in.
    Another feature request. I know you’re working on improving the images removal procedure so I won’t re-iterate that request. One thing I find annoying is to have to click on the preview checkbox for all uploaded images. It would be nice to add a setting in the cfg file to assume preview “on” for all attached images. This would eliminate the need for even showing the selector.

    While I would love to use this plugin I am having installation issues which honestly make me feel like a moron.
    When finishing the installation (I double checked the file locations and activated the plugin) during the “The table required to use Exhibit (wp_exhibit) is not installed.” stage after I click the link I simply get a 404. Any thoughts?
    Thanks for the help!

    I get stuck at this point too-unable to get the wp-exhibit table installed-404 error.
    Anybody any ideas?

    testing

    You folks with 404 errors: You need to follow the instructions closely when they say…

    Edit an existing post (or draft) and click on the link in the Exhibit area to create the required database table (if it doesn’t already exist).

    You can’t click that link on a new post, only an existing one. Assuming you did, you should change the “&” to a “?” in the URL that gives you a 404 error, and everything would work fine.
    I’ll see if I can smooth this out in the code.
    Also… preview_by_default is a configuration option in my current dev version. So please – I beg you – stop asking me for it. 🙂

    Sorry for the “testing” post.
    Ringmaster (or anyone else that has seen this) – I installed 1.2 Mingus last night and got it working and then installed version 1.1a of Exhibit. In the window below the “Reset to image/path” hotspot I have the following error:
    Current directory: /
    Warning: mkdir(/home/xbluene/public_html/requiest/images): Permission denied in /home/xbluene/public_html/requiest/wp-content/plugins/exhibitimg/exhibit10f.php on line 386
    ‘/home/xbluene/public_html/requiest/images’ is not a valid directory on this server. Check your image directory settings in Exhibit.
    You may need to create a user directory before you can use the file picker.
    I have the images directory created and have the CHMOD set to 777 (what should it be set to?) but I’m not sure what else to do. Line 386 does have to do with the directory but I can’t figure out where it is set.

    I’m an idiot – didn’t read the instructions properly. DISREGARD!!

    Is there a way to have paginated thumbnails begin on the first page of the post?

Viewing 15 replies - 16 through 30 (of 141 total)
  • The topic ‘Exhibit 1.1 Photo Gallery Plugin’ is closed to new replies.