Support » Plugins » Execphp error on widget admin screen

  • I am inserting a fairly complicated bit of code into a phpcode widget.

    After I save the changes, the admin screen gets messed up from the point of that installed widget on.. I have to go into mysql and delete the widget_execphp option to be able to make any changes.

    The code executes correctly, and the proper output appears on the browser when the blog is accessed. The problem is in the widget admin screen.

    The code I am inserting is:

    <?php if (!isset($OA_context)) $OA_context = array();
    $oaXmlRpc = new OA_XmlRpc(‘’, ‘/www/delivery/axmlrpc.php’, 0, false, 15);
    $adArray = $oaXmlRpc->view(‘zone:9’, 0, ”, ”, 0, $OA_context); echo $adArray[‘html’]; ?>

    I’ve looked at the code, and cannot see why this would trash the admin screen (php code widget is missing, displays only the title:


    and the save changes button does not appear.

Viewing 1 replies (of 1 total)
  • I am seeing a similar situation. I was getting %BEG_OF_TITLE%Most Popular Articles%END_OF_TITLE%, but I had a Popularity Contest plugin. All but two of the plugins in my second sidebar disappeared, along with the Save Changes button. Up until I tried adding a text (php) widget, it worked well. Now it says that I’m still using the widgets, but they do not appear in the widget admin area, nor on my site.

    I have tried disabling all Popularity Contest plugins, but the problem remains.

Viewing 1 replies (of 1 total)
  • The topic ‘Execphp error on widget admin screen’ is closed to new replies.