WordPress.org

Support

Support » Plugins and Hacks » Exec-PHP plugin not working

Exec-PHP plugin not working

  • Hi,

    I’ve installed Exec-PHP 3.2 plugin and have fulfilled all the requirements and even assigned the proper roles with Role Manager plugin, but it still doesn’t work. Any suggestions or thoughts on how to get it to work?

    Thanks,
    spellmank

Viewing 12 replies - 1 through 12 (of 12 total)
  • It’s not working for me, either. WordPress, itself, seems to reformat my php code so that it simply displays inside a post with a space in between the “<” and the “?php” thus stopping any php from actually executing. Any ideas why this is happening?

    You must have the wysiwyg editor turned off for it to work.

    Thanks for your reply, but I do have it turned off. I hate that thing. I like to see the actual code.

    Any other possibilities?

    I have run into the same problem. There is an extra space between the “<” and the “?php”

    I have turned of WYSIWYG as well as WordPress should correct invalidly nested XHTML automatically

    Any help much appreciated.

    Third requirement a post author must match: The author needs the ‘unfiltered_html’ capability. By default this is assigned to Administrators and Editors.

    Thanks McShelby. Also fulfilled that requirement:)

    Hmm, one last point: Which WordPress version are you using?

    doesn’t work for me on wp 2.1.1
    it adds <p> tags on the executed result from the php.

    Thanks McShelby. I use 2.0.7 and it seems my problem is not so much with exec-php, I updated to the latest version and that extra space was solved. Still have a slight problem with the way external rss feeds are displayed within a page but that’s another thread:)

    @dbasulto: The <p> tags are added by WP not by the Exec-PHP plugin.

    Here is the solution for 9 months of nothing.. I just did it. It’s the initial version but works.

    I will improve it tomorrow.

    Download it: http://wysiwyg-php.sniffer.net/

    My PuTTY bash prompt Theme page http://elite4putty.sniffer.net and my webpage http://www.sniffer.net/

    Best wishes,
    Bruno Ratnieks

    I experience the same problem with wp 2.3.2 and version 4.3 of php-exec. The code is output enclosed in <p> tags.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Exec-PHP plugin not working’ is closed to new replies.