Support » Plugin: Contact Form 7 » Exclusive not working

  • Resolved delawaregrad

    (@delawaregrad)



    I added a few checkboxes that are exclusive (ie, only one choice allowed). After the last update, it’s allowing multiple selections. Has something changed?

    [checkbox* your-fruit exclusive “Apple” “Banana” “Grape”]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Takayuki Miyoshi

    (@takayukister)

    I tested the form-tag in my testing environment and it worked correctly. I guess you have JavaScript issues. I can check that if you give the URL of the website.

    ppaatt

    (@ppaatt)

    I have this same problem :/

    @takayukister Can you check? please.

    my site: https://www.enginiety.com/software-engineer/

    I can’t send my form, because is problem with valid checkbox (as checkbox and as acceptance) Only on the Safari browser :/

    • This reply was modified 4 months ago by  ppaatt.
    • This reply was modified 4 months ago by  ppaatt.
    Katie H.

    (@khrycak)

    I am unable to reproduce the above issues.

    I tested exclusive checkboxes and acceptance checkboxes locally and with the http://www.enginiety.com/software-engineer/ form on these browsers:

    • Chrome Version 67.0.3396.99
    • Firefox 61.0.1
    • Safari Version 11.1.1
    • The checkboxes function as they should and the forms submitted successfully. Hopefully this helps you all get closer to a solution more quickly.

    delawaregrad

    (@delawaregrad)

    I have the latest version of those browsers and have tried on 3 different devices, with the same issue. The site isn’t live yet and is behind a coming soon screen.

    delawaregrad

    (@delawaregrad)

    If it helps – if I select more than one checkbox, when I submit the form, it only takes the last one selected. So it’s allowing multiple selections, but uses the last one as the selection.

    @delawaregrad – if you can give a link to your form here (as Takayuki Miyoshi requested) he & others can examine you form using Chrome Dev Tools to see in detail what is actually happening on your form.

    That’s by far the most useful information you can give at this stage.

    delawaregrad

    (@delawaregrad)

    Thanks to everyone for the feedback – I checked in Chrome and it was a JS error from a plugin that I have used before that sends the user to PayPal. I had it deactivated and when I reactivated it, the ‘redirect to PayPal’ changed from the recommended way to disabling the form’s JS. No idea how that happened.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.