Support » Plugin: Hustle - Email Marketing, Lead Generation, Optins, Popups » Excluding pages does not work

  • Resolved rsdkd

    (@rsdkd)


    Hi

    the plugin works fine, but is is showing on every page, even though I created an exclusion.

    I have 2 visibility rules:
    1. Only show logged out users (show when visitor status is logged out)
    2. Hide when on page “register” (because – the popup is to get you to the register page, but still pops up there) and on “login” as well.

    The first rule works, i dont get a popup when logged in. The second does not. I get the popup anywhere, and even when I try to register, the popup gets in my way.
    Did I miss something? I tried every setting on the “hide when” exception:
    Hide when only on these pages “registration” “login”
    Hide when everywhere exept these pages “registration” “login”

    I also tried this exception with only “registration”, but it still does not work.

    Can you help me with this? The whole idea of the popup is to force visitors to register, so they should not be abled to click the popup away, but this makes it impossible to register, when the popup also shows on that page 🙂

    Thank you

Viewing 4 replies - 1 through 4 (of 4 total)
  • rsdkd

    (@rsdkd)

    Update: I fixed it by putting the exceptions in one single exception, not two separate ones

    Plugin Support Jonathan – WPMU DEV Support

    (@wpmudev-support9)

    Hello @rsdkd

    I trust you’re doing well!

    Glad to know that you’ve found a solution! 🙂

    I hope you are doing well!

    I’ve marked this ticket as resolved. If you do have any followup questions or require further assistance feel free to reopen it and let us know here.

    Kind regards,
    Nastia

    I have a similar issue, where I can’t exclude a link, so users who come over from a specific newsletter won’t see the slide-in.
    I’ve tried adding to visibility options a link to mark the referer (mailchimp), to no success.

    Plugin Support Jonathan – WPMU DEV Support

    (@wpmudev-support9)

    Hello @talik2680

    I hope all is well!

    Thank you for posting in this thread, however as this is resolved for the original author, per WordPress forum regulations, please create a new thread and describe the issue you have.

    Have a good day!

    Kind regards,
    Nastia

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Excluding pages does not work’ is closed to new replies.