Support » Plugin: Table of Contents Plus » Excluding headlines: Special Characters

  • Resolved N-Z

    (@n-z)



    Hi,

    love the plugin so far (just please disable the German translation!) except for one problem: There are some special characters (like ä, ö, ü, ß and even é – I suppose all others qualify as well) that make problems when we want to eclude them from indexing for the content box.

    The exclusion works if you put the headings with the special characters in and save ONCE. But the plugin will replace them with something else. As soon as you save a second time, it will replace them again and thus invalidate the exclusion completely. Is it possible to fix this or to somehow mask the special characters in the TOC Advanced options?

    Example:
    1, heading proper: Franzöische Bulldogge (input before saving)
    2, once saved: Französische Bulldogge (still works for exclusion)
    3, saved again: Franz�¶sische Bulldogge (no longer works)

    Further saving (After additions or changes to the setup) extends this even more and no longer works. Worst about it: You do not even assume something happens or notice this until you look at an old page.

    https://wordpress.org/plugins/table-of-contents-plus/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Mike

    (@conjur3r)

    Thanks for spending the time to report and describe this to good detail. I will take a look at the saving mechanism, specifically with an internationalised hat to see if I can make it more compatibile.

    As I can’t read/speak German, what’s wrong with the German translation?

    The translation is just horrible to the point of being unintelligible. Looking at the name credited with it and the linked page, I am guessing that it has been done just to get the link.

    One example, the help entry for shortcodes actually starts in Dutch!
    Backtranslated it would be something like “[…]if attributes for the following shortcodes are left over, they will be back on the settings, that you defined at Einstellungen-Gt”.

    or at the end of the advanced settings:
    “This method you can include contents despite car/auto deactivate for content type to generate.” (With the right assumptions one can get it, but, well…)

    The checkbox
    “Verstecken Sie zunächst das Inhaltsverzeichnis” (“Hide the TOC at first”) did the exact opposite… it is hidden at first and becomes non-collapsed as standard when you activate this box.

    Grammatical flections are mostly ignored, sometimes it seems as if the words are just wrong and therefore unclear. Looks a lot like the first word an automatic translator came up with. In a few places it is ok but all in all quite mangled German. Had I had the choice, I’d have switched it to the English manual ASAP

    Or in short words, because it’s the same problem here at me:

    the plugin has problems with German Umlauts (see the example at the first posting here)

    Plugin Author Mike

    (@conjur3r)

    I’ve removed the German translation for the next release.

    For the special chars, I’ve been looking further into this and believe I have this narrowed down to PHP version. I’m running bleeding edge (5.5.12) and it works fine on my setup but I believe anyone running a version older than PHP 5.4 will have the issue you described.

    http://www.php.net/manual/en/function.htmlentities.php

    Like htmlspecialchars(), htmlentities() takes an optional third argument encoding which defines encoding used in conversion. From PHP 5.6.0, default_charset value is used as default. From PHP 5.4.0, UTF-8 is the default. PHP prior to 5.4.0, ISO-8859-1 is used as the default.

    ISO-8859 does not cover special chars which is probably why your chars are getting mangled. To address it, I will explicitly put UTF-8 in for all users.

    I’m using PHP 5.4 as well as the German version of WordPress.org (3.9.1) – and from 30 plugins in our network this one is the only one having problems with German Umlauts. So I guess, it is not the PHP version. (by the way, disabling all other plugins has not solved this issue – just saying).

    I just checked it, even ISO-8859 covers the German Umlauts Ä, Ö, Ü, ä, ö, ü, ß (http://de.wikipedia.org/wiki/ISO_8859)!

    Plugin Author Mike

    (@conjur3r)

    Are you able to try the changes in trunk and test?
    http://downloads.wordpress.org/plugin/table-of-contents-plus.zip

    Hi,

    Installed it today, seems to work now – at least after saving 3 times the special characters are still there, including the French accents.

    Thumbs up!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Excluding headlines: Special Characters’ is closed to new replies.